Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77402 - Possible root of fails in test script 'test_driver.pl' from built-in test suite
Summary: Possible root of fails in test script 'test_driver.pl' from built-in test suite
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: make
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 15:03 UTC by Andrey
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-06 15:05:04 UTC


Attachments (Terms of Use)
Patch for test_driver.pl (deleted)
2002-11-06 15:04 UTC, Andrey
no flags Details | Diff

Description Andrey 2002-11-06 15:03:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
There's possible root of fails in test script 'tests/test_driver.pl' from built-
in test suite. This script doesn't take in account environment 
variable 'LD_LIBRARY_PATH'. Script just clears this variable. It may affect 
behaviour of tests when 'make' is being built with compilers other than GNU GCC 
(I used Intel C++ compiler) because set of libraries used by another compilers 
may differ from that one used in GCC. In this example 'make' can't find 
necessary C-runtime library libcxa.so (It's used by Intel C++ compiler). May be 
it will be better to save value of this variable ? I tried to do this, it 
helps. I've attached patch 'test_driver.pl.patch'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. build 'make' with compiler other than GNU GCC (I used Intel C++ compiler)
2. start built-in tests with 'make check'

	

Actual Results:  built 'make' can't find some standard libraries which comes 
with the compiler (Intel C++ compiler). Tests don't run correctly. It implies a 
lot of fails (64).

Expected Results:  Tests should run correctly.

Additional info:

Comment 1 Andrey 2002-11-06 15:04:58 UTC
Created attachment 83864 [details]
Patch for test_driver.pl

Comment 2 Jakub Jelinek 2002-11-10 20:22:04 UTC
You should install the compiler properly if you plan to use it.
(like put it into /etc/ld.so.conf or put the library into /usr/lib).


Note You need to log in before you can comment on or make changes to this bug.