Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77387 - konsole super user mode shouldn't require password to be retyped
Summary: konsole super user mode shouldn't require password to be retyped
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 06:06 UTC by Joseph Shraibman
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-06 06:06:23 UTC


Attachments (Terms of Use)

Description Joseph Shraibman 2002-11-06 06:06:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The whole point of the konsole in super user mode is to be able to hit the new
button to get a new root shell. The kde that ships with rh 8.0 has a konsole
super user mode that requires the user to type in the root password each time.

The command:
konsole --type su
should be replaced with:
kdesu konsole

Version-Release number of selected component (if applicable):


How reproducible:
Always

Additional info:

Why is the konsole super user mode buried under Extras => System Tools rather
than in the System Tools directly?  For that matter why is anything that is in
Extras in there?

It was a pain to track this down because unlike kde 2.x that I have installed on
my 6.x system my rh 8.0 system won't let me edit the menu or view the properties
of the entries.

Comment 1 Ngo Than 2002-11-06 10:53:11 UTC
yes, it should be started with kdesu. The kdebase-3.0.4-2 or newer includes this
fix.

In 8.0 there are only the applications, which mostly are used, in the KDE main
menu. And others are in Extra.

I can edit menu without any problem. Could you give me more details how i can
reproduce this problem, please?


Note You need to log in before you can comment on or make changes to this bug.