Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77386 - Assertion failure in journal_write_metadata_buffer() at journal.c:408: "buffer_jdirty(jh2bh(jh_in))"
Summary: Assertion failure in journal_write_metadata_buffer() at journal.c:408: "buffe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Stephen Tweedie
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 05:47 UTC by Lim Chuan Jer
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-28 23:51:27 UTC


Attachments (Terms of Use)
LogFile Error code (deleted)
2002-11-06 05:58 UTC, Lim Chuan Jer
no flags Details
Error message as found in the system logfile after rebooting. (deleted)
2003-01-23 22:05 UTC, Robert Treat
no flags Details

Description Lim Chuan Jer 2002-11-06 05:47:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
My server running SMP 2.14.8.5 kernel (RedHAt 7.3).
Equipeded with 2 P3 933MHz and 1 GB RAM

Suddenly hanged up on me. Still pingable but all services dead. Upon rebooting, 
look through the log file and found the kernel error code. I've attached as 
attachment.

Any idea why is that so?


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

I search thru the repository and can only find a similar entry titled 
Assertion failure in journal_write_metadata_buffer() at 
journal.c:406: "buffer_jdirty(jh2bh(jh_in))"

But what i got at my system is c:408 instead of c:406. Not too sure whats the 
difference.

Comment 1 Lim Chuan Jer 2002-11-06 05:58:09 UTC
Created attachment 83806 [details]
LogFile Error code

Comment 2 Stephen Tweedie 2002-11-06 14:44:45 UTC
Have you seen any similar problems before?  Was there _anything_ else in the
logs related to possible ext3 or IO problems?

Comment 3 Lim Chuan Jer 2002-11-06 15:36:43 UTC
This is the 2nd time I encounter it on the same machine in 4 months time. Not 
very frequent, but is interested to know whats the cause of it

Comment 4 Robert Treat 2003-01-23 22:05:31 UTC
Created attachment 89554 [details]
Error message as found in the system logfile after rebooting.

Comment 5 Robert Treat 2003-01-24 21:41:07 UTC
I posted the logfile yesterday, here is the explination: We recieved this error
on our server running Red Hat 7.3 and 2.4.18-5smp. The server is a dedicated
postgresql database server. I noticed in the last message for bug # 64107 that
the error was recieved on heavy IO load, and I think this might have been a
similar problem for us.  We had turned on query logging on our database which
was producing data at a rate of about 2.6GB in around 6 hours. Once the error
occured, we had no access to the server and had to power off/on. 

Comment 6 Stephen Tweedie 2003-01-28 23:51:27 UTC
2.4.18-3 had a problem that triggered this quite frequently, and that was fixed
in 2.4.18-5.  However, I found another rare case that could sometimes still
cause it even in that kernel, and that should be fixed in all subsequent errata
later than 2.4.18-5.  Please reopen this report if you still have the problem on
a current kernel.


Note You need to log in before you can comment on or make changes to this bug.