Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77382 - kudzu controlled entries in fstab are deleted after removing USB memory stick
Summary: kudzu controlled entries in fstab are deleted after removing USB memory stick
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 04:06 UTC by Tuan Hoang
Modified: 2014-03-17 02:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-13 22:01:56 UTC


Attachments (Terms of Use)

Description Tuan Hoang 2002-11-06 04:06:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
When I use my 64MB Sony Micro Vault (USB memory stick), I typically mount it as
a SCSI device.  ex: mount /dev/sda /mnt/memorystick
This works great and all.  The problem is that when I unmount the drive and
physically remove the USB memory stick, it removes any entries in /etc/fstab
that have the kudzu option.  In my case, every time I remove the USB memory
stick, my DVD/CD-RW combo drive (using ide-scsi) entry is removed from
/etc/fstab, the link /dev/cdrom is removed, and also the /mnt/cdrom directory is
removed.

They system has been fully updated and using the latest kernel 2.4.18-17.8.0.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert and mount the Sony Micro Vault (USB memory stick).
2. Unmount and remove the Sony Micro Vault.
3. Kudzu controlled entries in /etc/fstab are removed along with links, files
and directories associated with the entry.
	

Actual Results:  Every time I remove the USB memory stick, my DVD/CD-RW combo
drive (using ide-scsi) entry is removed from /etc/fstab, the link /dev/cdrom is
removed, and also the /mnt/cdrom directory is removed.

Expected Results:  The devices should stay or be re-detected properly.

Additional info:

Comment 1 Thomas Schuett 2003-01-11 17:15:30 UTC
Bug "works" with any usb drive - spooky


Comment 2 Bill Nottingham 2003-02-13 22:01:56 UTC
Fixed in 0.99.96-1.


Note You need to log in before you can comment on or make changes to this bug.