Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77381 - i810 XFree 4.2 driver doesn't work properly on Intel 845GEBV2
Summary: i810 XFree 4.2 driver doesn't work properly on Intel 845GEBV2
Keywords:
Status: CLOSED DUPLICATE of bug 74974
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 00:48 UTC by Yan-Fa Li
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-06 15:17:44 UTC


Attachments (Terms of Use)

Description Yan-Fa Li 2002-11-06 00:48:22 UTC
Description of Problem:

When redhat 8.0 installs it detects the built in video card,
an i810 variant.  However something is awry with this version
of the i810 and it causes weird font behavior under KDE
and memory leaks under gnome.  Switching to fbdev is a viable
work around.

http://support.intel.com/support/motherboards/desktop/D845GEBV2/

Version-Release number of selected component (if applicable):
XFree86-4.2.0-72

How Reproducible:
simple do a default install of redhat 8.0 on this motherboard.

Steps to Reproduce:
1. install redhat 8.0
2. login
3. start a terminal and watch the memory get eaten

Actual Results:


Expected Results:


Additional Information:

Comment 1 Mike A. Harris 2002-11-06 15:17:37 UTC
This video hardware is unsupported.

Comment 2 Mike A. Harris 2002-11-06 15:25:16 UTC
See bug duplicate for details.

*** This bug has been marked as a duplicate of 74974 ***

Comment 3 Yan-Fa Li 2002-11-06 16:56:26 UTC
that's really sad since this is a brand new board, ah well, wouldn't it be 
easier to fix redhat-config-xfree86 or Xconfigurator to simply detect this 
board and pick fbdev ?

Comment 4 Mike A. Harris 2002-12-12 13:10:37 UTC
Yes, it is unfortunate that XFree86 4.2.x does not support this hardware,
however that's sadly the way it is currently.  One should always first
find out what hardware is officially supported prior to making a hardware
purchase.

No, it is not easier to 'fix' redhat-config-xfree86 to use fbdev.  It is
intentional that it does not support fbdev.  Hardware that does not have
a native video driver in XFree86 is unsupported by Red Hat.  During beta
testing, we default known unsupported hardware to using the "vesa" driver,
and if that happens to work for some people and no major bug reports come
back, then we leave the given unsupported hardware defaulting to "vesa",
however it is still unsupported completely by us, and only provided as
a convenience to users who would otherwise have no working video at all.
There are no plans to add code to the config tools for handling fbdev,
at this time, and no plans to support X using fbdev.  XFree86 will generally
work with fbdev assuming it is configured correctly, however that is
merely "provided" for convenience as well, and not supported.

Every feature that is implemented requires developer time to do so, and
then to debug, receive bug reports, and fix them.  Doing so would be
"supporting" something that we straight out state we do not officially
support.

i845 will be supported in the next release of Red Hat Linux, and there
is experimental (but currently broken) support in rawhide.


Note You need to log in before you can comment on or make changes to this bug.