Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77345 - (i830M) switching from X to text-mode VT crashes X
Summary: (i830M) switching from X to text-mode VT crashes X
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-05 16:21 UTC by David Monniaux
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-26 20:37:42 UTC


Attachments (Terms of Use)
XFree86 log (deleted)
2002-11-05 16:22 UTC, David Monniaux
no flags Details
XF86Config (deleted)
2002-11-05 16:40 UTC, David Monniaux
no flags Details
XFree86 log when using kernel 2.4.18-17.8.0 (deleted)
2002-11-05 18:46 UTC, David Monniaux
no flags Details

Description David Monniaux 2002-11-05 16:21:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
With XFree86-4.2.99.2.20021105 and drm-4.2.99.2: switching from the X VT to a
text-mode VT with the DRI module loaded makes X crash.

The crash happens when switching FROM X, not TO X, and does NOT happen if not
loading DRI. However, it is not necessary to run any OpenGL application when
switching VTs for it to crash. Unless switching VTs, DRI OpenGL works fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run X with the DRI module.
2.Hit Control-Alt-F1.
	

Actual Results:  X crashes and gives error messages on the console.

Expected Results:  It should have gone on quietly.

Additional info:

Kernel: 2.4.20-rc1, but with the drm-4.2.99.2 modules.

Comment 1 David Monniaux 2002-11-05 16:22:31 UTC
Created attachment 83704 [details]
XFree86 log

Comment 2 David Monniaux 2002-11-05 16:40:17 UTC
Created attachment 83705 [details]
XF86Config

Comment 3 David Monniaux 2002-11-05 18:45:35 UTC
Now using the RedHat 8.0 update kernel 2.4.18-17.8.0:
it is now possible to switch from X to text VTs without crashing X.

However, I crashed X when switching VTs while running TuxRacer (a game that uses
OpenGL and thus DRI).

Comment 4 David Monniaux 2002-11-05 18:46:48 UTC
Created attachment 83724 [details]
XFree86 log when using kernel 2.4.18-17.8.0

Comment 5 Mike A. Harris 2002-11-29 10:07:42 UTC
Can you try using the following option to see what happens:

        Option  "XaaNoSolidFillRect"

Does it change anything?




Comment 6 Mike A. Harris 2002-12-15 09:41:16 UTC
This is likely related to bug #79205

Comment 7 Mike A. Harris 2002-12-26 20:37:42 UTC
You've filed several bugs lately, and then ditched them after being requested
for more information.  I ask for more information because it is required in
order for me to do anything or even investigate the problem.  Since you've
more or less ignored all of my requests for more information in several bug
reports, I'm not able to look into the issues you have reported any further.

I therefore assume that either the problem no longer exists for you, or else
you are no longer interested in having the issue tracked and/or investigated.

If this assumption is wrong, then please update the bug reports as requested,
and reopen them.


Note You need to log in before you can comment on or make changes to this bug.