Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77339 - bash incorrectly expands wildcards
Summary: bash incorrectly expands wildcards
Keywords:
Status: CLOSED DUPLICATE of bug 77115
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-05 13:56 UTC by Leonid Mamtchenkov
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-05 13:56:56 UTC


Attachments (Terms of Use)

Description Leonid Mamtchenkov 2002-11-05 13:56:49 UTC
Description of Problem:
Bash incorrectly expands wildcards.


Version-Release number of selected component (if applicable):
bash-2.05b-5

How Reproducible:
Always

Steps to Reproduce:
1. touch X11 x11 Y11 y11
2. ls [x-y]*
3. ls [X-Y]*

Actual Results:
For step 2: x11  X11  y11
For step 3: X11  y11  Y11

Expected Results:
For step 2: x11 y11
For step 3: X11 Y11

Additional Information:
I have tested this behavior on several other versions of RedHat Linux (6.2, 7.2,
7.3) and it behaves correctly.

Comment 1 Tim Waugh 2002-11-05 14:00:27 UTC

*** This bug has been marked as a duplicate of 77115 ***


Note You need to log in before you can comment on or make changes to this bug.