Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77332 - RFE: Enable speedstep for PIII (Coppermine) mobile CPUs
Summary: RFE: Enable speedstep for PIII (Coppermine) mobile CPUs
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On: 81910
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-05 06:46 UTC by shmuelp
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-08 15:39:30 UTC


Attachments (Terms of Use)

Description shmuelp 2002-11-05 06:46:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The ability to throttle the CPU of a notebook based on battery/AC power is very
important for extending battery life.  For intel chips, this is based on the
kernel file arch/i386/kernel/speedstep.c.  This is is already in the RH kernel.
 However, the file as written will not work by default with PIII (Coppermine)
CPUs, requiring the user to remove a line and recompile.  This is meant as a
check that the user really has a speedstep-capable processor, since the module
does not check for that.  Perhaps that line could be removed already, on the
presumption that someone without a speedstep-capable processor won't try to
insert the module?

ALternatively, the cpufreq patches to the 2.5 kernel seem to detect the CPU just
fine...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot kernel on speedstep-capable PIII (Coppermine) CPU
2. Run 'modprobe speedstep'


Actual Results:  [root@magrathea root]# modprobe speedstep
/lib/modules/2.4.18-14/kernel/arch/i386/kernel/speedstep.o: init_module: No such
device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.18-14/kernel/arch/i386/kernel/speedstep.o: insmod
/lib/modules/2.4.18-14/kernel/arch/i386/kernel/speedstep.o failed
/lib/modules/2.4.18-14/kernel/arch/i386/kernel/speedstep.o: insmod speedstep failed
[root@magrathea root]# tail -5 /var/log/messages
Nov  5 01:39:38 magrathea kernel: cpufreq: Intel(R) SpeedStep(TM) support
$Revision: 1.34 $
Nov  5 01:39:38 magrathea kernel: cpufreq: Intel PIII (Coppermine) detected. If
you are sure this is a
Nov  5 01:39:38 magrathea kernel: cpufreq: SpeedStep capable processor, please
remove line 483 in
Nov  5 01:39:38 magrathea kernel: cpufreq:
linux/arch/i386/kernel/cpufreq/speedstep.c.
Nov  5 01:39:38 magrathea kernel: cpufreq: Intel(R) SpeedStep(TM) for this
processor not (yet) available.


Expected Results:  Speedstep module should insert cleanly into kernel

Additional info:

[root@magrathea root]# uname -a
Linux magrathea 2.4.18-14 #1 Wed Sep 4 13:35:50 EDT 2002 i686 i686 i386 GNU/Linux
[root@magrathea root]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 701.598
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat
pse36 mmx fxsr sse
bogomips        : 1393.96

Comment 1 Aleksey Nogin 2003-02-14 07:53:24 UTC
Have you tried passing the speedstep_coppermine=1 parameter to the module? Have
you tried the most recent kernels from Rawhide?

Comment 2 Alan Cox 2003-06-08 15:39:30 UTC
No reply, current speed step code updates in current errata
Closing



Note You need to log in before you can comment on or make changes to this bug.