Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77311 - Support for using UTF-8 as input encoding in LaTeX documents
Summary: Support for using UTF-8 as input encoding in LaTeX documents
Keywords:
Status: CLOSED DUPLICATE of bug 71498
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 8.0
Hardware: i586
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-04 23:50 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-04 23:50:58 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-04 23:50:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Please provide the ucs.sty package or a simular one.

The mentioned package contains support for using UTF-8
as input encoding in LaTeX documents.

The simplest use of that package is to add

  \usepackage{ucs}
  \usepackage[utf8]{inputenc}

to the LaTeX source instead of the traditionally

  \usepackage[latin1]{inputenc}

after editing the document with UTF-8 input.

The most recent version of the package can 
be found at

http://www.unruh.de/DniQ/latex/unicode/

Happy TeX'ing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter UTF-8 characters (try the Scandinavian 'f', 'x', 'e') in 
   a LaTeX document from Emacs.
2. Run latex document.tex and, after hitting return on the error, 
   try to view it in xdvi.

Actual Results:  Bad DVI encoding.

Additional info:

With the ucs.sty package installed and mentioned 
in the LaTeX document everything's working fine.

Comment 1 Tim Waugh 2002-11-05 11:56:23 UTC

*** This bug has been marked as a duplicate of 71498 ***


Note You need to log in before you can comment on or make changes to this bug.