Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77267 - RFE: auto-detection of network profile and associated update to gui
Summary: RFE: auto-detection of network profile and associated update to gui
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 75961 (view as bug list)
Depends On:
Blocks: 81720
TreeView+ depends on / blocked
 
Reported: 2002-11-04 15:51 UTC by Jon DeSena
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-13 10:58:47 UTC


Attachments (Terms of Use)
Patches for auto-detection and activation of network profiles (deleted)
2002-11-04 15:53 UTC, Jon DeSena
no flags Details

Description Jon DeSena 2002-11-04 15:51:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
The system should be able to determine what network profile to use based on the
network connection. This way, when the computer is plugged into a different
network, the computer could set up the network itself, if so desired. This, of
course, would require that the   user first set up a profile for all networks
that the computer will be attached to first. Once this is done, however,
switching networks would require a minimal of user intervention. This is
especially handy for laptop owners.
This really addresses a combination of issues.
1) A valid profile needs to be able to be determined by the computer, if one is
available. If none of the configured profiles work, the computer should do
something reasonable. If more than one are valid, also make some reasonable choice.
2) Profiles should be allowed to be activated at boot.
3) The network gui needs to be profile "aware" and allow for manual profile
selection (override).
This requires changes to the initscripts package (in my determination) as well.
See my patch attachment which addresses this RFE.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create some profiles
2.Try to easily activate one -- this requires too many hard to understand steps
(shut off each net device, switch profile, start each new net device...)
3.Wish this could be automated instead :)
	

Actual Results:  If you do not shut off all net devices not in the profile you
intend to switch to before switching profiles, you will not be able to do so
once the switch has been made (very frustrating). At least a profile
switch&activate command should be supplied (I have done so in my attached patch).

Expected Results:  Profile change should be a lot easier and intuitive to do.
Also, the computer should have a mechanism to make a reasnonable (override-able)
profile determination on its own

Additional info:

I am filing this as a RFE, but it addresses what are really some bugs as well.

Comment 1 Jon DeSena 2002-11-04 15:53:42 UTC
Created attachment 83504 [details]
Patches for auto-detection and activation of network profiles

Comment 2 Harald Hoyer 2003-01-13 12:25:53 UTC
*** Bug 75961 has been marked as a duplicate of this bug. ***

Comment 3 Alex Cruise 2003-01-15 01:20:51 UTC
This looks like just what I need, having 4-5 networks that I connect to on a regular basis from the same laptop.  How do I rebuild these packages with the patches? :) 


Note You need to log in before you can comment on or make changes to this bug.