Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77263 - Cyrillic font/Russian Language support
Summary: Cyrillic font/Russian Language support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Jay Turner
URL:
Whiteboard: triage|leonardjo|closed|rawhide
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-04 14:31 UTC by Pasha
Modified: 2015-01-08 00:01 UTC (History)
5 users (show)

Fixed In Version: 4.6.1-0.8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-26 16:43:53 UTC


Attachments (Terms of Use)

Description Pasha 2002-11-04 14:31:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2a) Gecko/20020910

Description of problem:
Problems with Russiam language/font/encoding.
UTF8 - is bad.
Problem with mc - impossible to work.
Also problem with "make menuconfig" impossible to compile a kernel because the
text is unreadable. 
changing i18n to LANG="en_US.iso885915" works, but how to make back koi8-r
support? copying file i18n doesn't helped :((( The situation became badder.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install with Russian language support.
2. Use mc(midnight commander) of make menuconfig

	

Actual Results:  No proper support for Russian Language, I use do downgrade back
to RH7.3.
Also I am not support you decision about xmms mp3 support I have to install
RH7.3 again. 

Expected Results:  To see normal Russian letters support and to see the Linux I
haven't seem before. Yeah, you ad was at time I haven't seen so many problems
since RedHat 5.1.

Additional info:

no additional information me only an advice to make choose during installation
of RH8.1 if it follows what charset to use koi8-r or UTF8.

Comment 1 Leonid Mamtchenkov 2002-11-04 15:58:01 UTC
While I have to agree about bad support of Russian in both console and X, it is
still possible to configure.  This is what I do have in my /etc/sysconfig/i18n:
LANGUAGE="en_US.utf8"
LANG="en_US.utf8"
LC_LOCALE="ru_RU.utf8"
LC_CTYPE="ru_RU.utf8"
LC_MESSAGES="en_US.utf8"

And here is the content of my /etc/sysconfig/keyboard:
KEYTABLE="ru1"

I am still fighting with several problems in console, but in X everything works
fine.  I had to move away from gnome-terminal and konsole, though to the
plain-old-bug-free (grin) xterm.  This is how I start xterm:
LC_CTYPE=ru_RU.UTF-8 xterm -fn
'-Misc-Fixed-Medium-R-Normal--20-200-75-75-C-100-ISO10646-1' -bg black -fg green

Midnight Commander does not understand utf-8, but at least it uses
pseudo-graphics properly.  There are also few other problems with unicode,
specifically for me - icq and irc.

As to the question of mp3 support, I support Redhat.  Those, who miss the
functionality, can get it back easily by installing xmms/mpg123 from
http://freshrpms.net .  Those RPMs are specifically built for latest versions of
RedHat and DO work.  Try them.

Comment 2 Leonard den Ottolander 2004-10-26 16:41:48 UTC
There have been a lot of UTF-8 improvements. Not sure if the original
report actually is a bug or bad configuration, but closing RAWHIDE.



Note You need to log in before you can comment on or make changes to this bug.