Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77248 - Memory leaks in miniChinput
Summary: Memory leaks in miniChinput
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: miniChinput
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact: Bill Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-04 08:12 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-06 06:32:44 UTC


Attachments (Terms of Use)
Patch file. (deleted)
2002-11-07 23:58 UTC, Need Real Name
no flags Details | Diff

Description Need Real Name 2002-11-04 08:12:59 UTC
Description of Problem:

I have found quite a few memory leaks in miniChinput-0.0.3-27.
SInce I don't know how to attach files here, I'll send detailed
information upon request.


Version-Release number of selected component (if applicable):
0.0.3-27

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Yu Shao 2002-11-07 05:55:41 UTC
Thank you for your information, you can use "Attachments: Create a new
attachment" link to attach file, or you can send email directly to me, any
information is welcome. Thanks

Comment 2 Need Real Name 2002-11-07 23:58:53 UTC
Created attachment 84105 [details]
Patch file.

Comment 3 Need Real Name 2002-11-08 00:05:19 UTC
I have attached my patch file.

(it's strange that I have attached it two days ago
but it wasn't there). 

The memory leaks were found using dmalloc.

Comment 4 Need Real Name 2002-11-08 00:06:04 UTC
I have attached my patch file.

(it's strange that I have attached it two days ago
but it wasn't there). 

The memory leaks were found using dmalloc.

Comment 5 Need Real Name 2002-12-07 04:03:00 UTC
Thanks!
That's a good news for me!
I meet this problem while I use mwm as the xwindow manager.
Anyway, I will patch my miniChinput with your codes.
btw. did you test miniChinput in mwm?

Comment 6 Lawrence Lim 2004-07-13 09:47:06 UTC
Is this still valid?

Comment 7 Lawrence Lim 2004-09-06 06:32:44 UTC
Please download the latest version miniChinput-0.0.3-58 from rawhide
and reopen this bug if problem persists.


Note You need to log in before you can comment on or make changes to this bug.