Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77243 - Tar creates empty files in some cases.
Summary: Tar creates empty files in some cases.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Ben Levenson
URL:
Whiteboard:
: 77683 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-04 04:08 UTC by Yannick Patois
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-20 09:15:51 UTC


Attachments (Terms of Use)

Description Yannick Patois 2002-11-04 04:08:49 UTC
Description of Problem:
TAR creates empty archive when both an exclude pattern file and an absolute path
to tar is given.

Version-Release number of selected component (if applicable):
1.13.25-4.7.1

How Reproducible:
Always

Steps to Reproduce:
1. mkdir tarbug;cd tarbug; echo "*.o#" | tr '#' '\n' > exclude;touch foo
2. tar cvZ -X exclude -N "20021103 04:25:36" -f tarbug.tgz `pwd`/foo
3. 

Actual Results:
Empty tar file is created.

Expected Results:
Tar file containing 'foo'

Additional Information:
tar-1.13.19-6 does work.

Take this as a SERIOUS issue: many backup system rely on explude pattern file +
backing up absolute paths. Having empty backup is quite nasty.
My backup system just broke on this !

I'm not sure if the -N flag does matter. Didnt checked.

Comment 1 Jeff Johnson 2002-11-12 11:59:43 UTC
*** Bug 77683 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.