Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77242 - nohup doesn't work under openssh
Summary: nohup doesn't work under openssh
Keywords:
Status: CLOSED DUPLICATE of bug 39128
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-04 03:38 UTC by hjl
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-02-04 10:57:09 UTC


Attachments (Terms of Use)
A patch (deleted)
2002-11-04 05:05 UTC, hjl
no flags Details | Diff
Hang-on-exit fix (deleted)
2003-02-06 23:21 UTC, franz.sirl-kernel
no flags Details | Diff

Description hjl 2002-11-04 03:38:17 UTC
When I ssh into RedHat 8.0

# nohup sleep 70&
# exit

ssh won't quit.

Comment 1 hjl 2002-11-04 05:05:47 UTC
Created attachment 83424 [details]
A patch

Comment 2 hjl 2002-11-04 05:06:28 UTC
I uploaded a patch, which seems to work for me. Any
comments?

Comment 3 franz.sirl-kernel 2002-12-29 12:45:52 UTC
I tried the patch with openssh-3.5p1-2 and it doesn't change anything for me, the logout is still 
delayed by 70 seconds if I use your example. 
BTW, I think this is a very long-standing bug in openssh, it was introduced already around 
2.3/2.4 IIRC. 
 

Comment 4 franz.sirl-kernel 2003-02-06 23:21:48 UTC
Created attachment 89907 [details]
Hang-on-exit fix

This is a port of the patch posted here:

http://marc.theaimsgroup.com/?l=openssh-unix-dev&m=102863079720412&w=2

to openssh-3.5p1-4.
Besides that I also changed the default, so to get the hanging behaviour (no
potential data loss) back, put "CloseOnSIGCHILD no" into your sshd_config.

Seems to work fine so far on a 7.3 i686 and a rawhide PPC machine.

Comment 5 Tomas Mraz 2005-02-04 10:57:09 UTC

*** This bug has been marked as a duplicate of 39128 ***


Note You need to log in before you can comment on or make changes to this bug.