Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77237 - new hdb harddrive only "findable" as hdd device?
Summary: new hdb harddrive only "findable" as hdd device?
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-04 00:37 UTC by Dan Clowater
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-04 22:31:06 UTC


Attachments (Terms of Use)

Description Dan Clowater 2002-11-04 00:37:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I first double checked to see that the drive was slave and on ide0
chain.  Having done that and scratched my head I found this in my syslogger:

hda: QUANTUM FIREBALLP LM20.5, ATA DISK drive
hdb: QUANTUM FIREBALL EX6.4A, ATA DISK drive
hdc: Pioneer DVD-ROM ATAPIModel DVD-105S 011, ATAPI CD/DVD-ROM drive
hdd: SONY CD-RW CRX175E, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15

But when trying to fdisk the drive I can only seem to find it when I do a fdisk
/dev/hdd.

(I was not sure where to post this - I thought it mounting related though.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. installed the drive as slave on ide0
2. boot up
3. no drive @ hdb
	

Actual Results:  I tried accessing the drive but get the error:

# ./fdisk /dev/hdb

Unable to open /dev/hdb
#

but curiously I tried hdc and hdd and hdd was willing to be fdisked!?!? despite
that is is technically my CDRW.

Expected Results:  hdb = hdb, fdisk, write fs, happy.

Additional info:

Tried posting to comp.os.linux.hardware and psyche-listserv.  Without resolution.

Comment 1 Dan Clowater 2002-11-04 22:30:59 UTC
To follow this up - I could not fdisk the hdd partition - as I came to surmise
that it is the write buffer on my CDRW.

So - I used pqmagic to clean and make my new 6GB drive into an ext3 system - yet
I cannot see/mount/fdisk/etc....anything to my hdb - I would think the drive
messed up - but I can see it with windows.

Comment 2 Elliot Lee 2002-12-10 20:59:45 UTC
Sorry, this is one of those "call support because you have a totally weird hardware setup" 
type of bugs. :\ Those symptoms are really strange.

If you have a way for me to reproduce the problem on any random system, it'll be easier 
for me to try solving it.

Comment 3 Dan Clowater 2002-12-10 21:46:55 UTC
Well I sorted this one out - forgot about the bug report - I had the burner in
the hdb slot before - so the grub.conf still pointed the scsi=ide thing to hdb.
 After I changed that to point to hdd (where the burner is) - no problems! 
Everything works great now.


Note You need to log in before you can comment on or make changes to this bug.