Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77232 - cyrus sasl should be compiled --with-lda
Summary: cyrus sasl should be compiled --with-lda
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cyrus-sasl
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-03 21:48 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version: 2.1.18-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-07 20:05:36 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-03 21:48:17 UTC
Description of Problem:
cyrus-saslauthd does not come with ldap out of the box.

Version-Release number of selected component (if applicable):
2.1.7

How Reproducible:
always

Steps to Reproduce:
1. try setting the saslauthd mech to "ldap" in the init.d file.
2. 
3. 

Actual Results:
saslauthd does not support ldap.

Expected Results:


Additional Information:
I recompiled the saslauthd rpm --with-ldap and installed it. It works great, but
 the reason for using 8.0 is so that there's less compiling in the future :/

Comment 1 Jim Richardson 2002-12-03 13:37:25 UTC
Same issue exists on 8.0 except when you attempt to recompile the src.rpm it 
fails due to a dependency on autoconf213.

Comment 2 Jim Richardson 2002-12-03 13:52:44 UTC
Well digging in the CDs I found the autoconf213 rpm, and suprisingly after 
installing it is seems to coexist quite nicely with autoconf-2.53-8. So I was 
able to recompile with the --with-ldap option added to the cyrus-sasl.spec 
file.

Comment 3 Bill Nottingham 2006-08-07 19:39:55 UTC
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.



Note You need to log in before you can comment on or make changes to this bug.