Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77228 - quote keys must be hit twice for keystroke to be recognized
Summary: quote keys must be hit twice for keystroke to be recognized
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-03 19:57 UTC by Justin Georgeson
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-03 23:16:44 UTC


Attachments (Terms of Use)
XF86 log file (deleted)
2002-11-03 20:01 UTC, Justin Georgeson
no flags Details
XF86 config file (deleted)
2002-11-03 20:02 UTC, Justin Georgeson
no flags Details
lspci -n listing (deleted)
2002-11-03 20:03 UTC, Justin Georgeson
no flags Details

Description Justin Georgeson 2002-11-03 19:57:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
I just upgraded to XFree86-4.2.99.2-0.20021101.4 from
XFree86-4.2.99.2-0.20021018.5, and the quote keys must be hit more than once to
register the keystroke. the backquote key (`) must be hit twice, while the
single quote key (o?=) must be hit three times. This behavior is only exhibited in X.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Hit either the back quote or single quote key, in X

	

Actual Results:  Must hit the key 2 or 3 times to register keystroke

Expected Results:  Should only have to hit key once.

Additional info:

Comment 1 Justin Georgeson 2002-11-03 20:00:08 UTC
Guess I should have proofread before commiting. I just noticed that it show o?=
instead of a single quote. Perhaps this is a little deeper than I first thought.

Comment 2 Justin Georgeson 2002-11-03 20:01:28 UTC
Created attachment 83365 [details]
XF86 log file

Comment 3 Justin Georgeson 2002-11-03 20:02:11 UTC
Created attachment 83366 [details]
XF86 config file

Comment 4 Justin Georgeson 2002-11-03 20:03:54 UTC
Created attachment 83367 [details]
lspci -n listing

Comment 5 Mike A. Harris 2002-11-03 23:08:21 UTC
This is standard behaviour if deadkeys are enabled.  Typing any of the
quote keys, the :, and various other keys enables deadkey mode which
is used to compose accented glyphs for various other languages such as
French, German, etc.

Are you positive that you do not have deadkeys enabled?  I see that you
have chosen the US International keyboard layout, which I believe has
deadkeys by default.

Option "XkbLayout"	"us_intl"

Try changing this to just "us", then restarting X.  Does that solve the
problem?


Comment 6 Justin Georgeson 2002-11-03 23:16:37 UTC
That fixed it. Thanks. :)

Comment 7 Mike A. Harris 2002-11-04 07:03:18 UTC
Ok, so this was just a misconfiguration then, not a bug.  Deadkeys are a
method of inputting accented characters quickly.  Personally I dislike
deadkeys the same as you do.  ;o)   But some International users prefer
deadkeys as an easy way to input accents, for example by typing:

'o   - to get an o with a ' accent on top, or
:o   - to get an o with a .. on top

Beware of the international keyboard!  ;o)

Closing NOTABUG


Note You need to log in before you can comment on or make changes to this bug.