Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77221 - Enviroment not exported to up/down local programs
Summary: Enviroment not exported to up/down local programs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-03 16:07 UTC by Andrew E. Mileski
Modified: 2015-01-08 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-16 16:13:15 UTC


Attachments (Terms of Use)

Description Andrew E. Mileski 2002-11-03 16:07:16 UTC
The /etc/ppp/ip-up and /etc/ppp/ip-down scripts don't export enviroment
variables from pppd:

DEVICE IFNAME IPLOCAL IPREMOTE PEERNAME SPEED ORIG_UID PPPLOGNAME CONNECT_TIME
BYTES_SENT BYTES_RCVD LINKNAME

Not all of these are available as command-line args, so they must be exported.

Comment 1 Thomas Woerner 2004-08-16 16:13:15 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.