Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77218 - ls -l shows weird letters after month name
Summary: ls -l shows weird letters after month name
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-03 13:31 UTC by Petri T. Koistinen
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-08 16:37:29 UTC


Attachments (Terms of Use)
Pictures describes the unicode problem. (deleted)
2002-11-03 13:32 UTC, Petri T. Koistinen
no flags Details

Description Petri T. Koistinen 2002-11-03 13:31:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
With my locale settings "ls -l" shows weird letters after month name.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set fi_FI.UTF-8 locale
2. Run "ls -l"



Actual Results:  See attached picture.

Expected Results:  Picture explains.

Additional info:

Comment 1 Petri T. Koistinen 2002-11-03 13:32:31 UTC
Created attachment 83324 [details]
Pictures describes the unicode problem.

Comment 2 Petri T. Koistinen 2002-11-03 13:34:36 UTC
Date when this bug was posted, in case you don't know Finnish month names by heart.

[petri@dsl-hkigw4e42 petri]$ date
su marras  3 15:33:35 EET 2002
[petri@dsl-hkigw4e42 petri]$ date -R
Sun, 03 Nov 2002 15:33:41 +0200
[petri@dsl-hkigw4e42 petri]$ 


Comment 3 Tim Waugh 2002-11-04 12:27:58 UTC
Did fileutils-4.1.9-10 have the same behaviour?

Comment 4 Tim Waugh 2002-11-04 12:31:58 UTC
I can't reproduce this problem.  UTF-8 output looks okay here in xterm,
gnome-terminal.  Which terminal application are you using?

Comment 5 Petri T. Koistinen 2002-11-04 20:42:43 UTC
I use xterm, try setting these and reboot:

$ cat /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="fi-latin1"
$ cat /etc/sysconfig/i18n
LANG="fi_FI.UTF-8"
LC_CTYPE="fi_FI@euro"
SUPPORTED="en_GB.UTF-8:en_GB:en:fi_FI.UTF-8:fi_FI:fi"
SYSFONT="latarcyrheb-sun16"

Comment 6 Tim Waugh 2002-11-07 16:26:32 UTC
You're mixing encodings there---'fi_FI.UTF-8' is a UTF-8 encoding but
'fi_FI@euro' is ISO-8859-15.

Did you edit that file by hand or use redhat-config-keyboard or some such tool?

Comment 7 Petri T. Koistinen 2002-11-08 16:37:23 UTC
I edited it by hand, and I fixed it to this form:

[petri@dsl-hkigw4e42 petri]$ sudo cat /etc/sysconfig/i18n  
LANG="fi_FI@euro"
LC_CTYPE="fi_FI@euro"
SUPPORTED="en_GB.UTF-8:en_GB:en:fi_FI.UTF-8:fi_FI:fi:fi_FI@euro"
SYSFONT="latarcyrheb-sun16"

ls -l seems to be working now.

Still, what I saw is a bug, in my opinion. It should be fixed. If not, care to
explain, why not? Thanks!

Comment 8 Tim Waugh 2002-11-08 16:53:38 UTC
It makes no sense to use locales with two entirely different encodings for LANG
and LC_CTYPE.


Note You need to log in before you can comment on or make changes to this bug.