Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77207 - kdeinit signal 11 core file generated..
Summary: kdeinit signal 11 core file generated..
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-03 02:59 UTC by Kyle
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-14 09:22:06 UTC


Attachments (Terms of Use)

Description Kyle 2002-11-03 02:59:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
core.29303 file generated from signal 11 of kdeinit. logging in i assume..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.logging in
2.generated core.29303
3.
	

Actual Results:  core.29303: ELF 32-bit LSB core file of 'kdeinit' (signal 11),
Intel 80386, version 1 (SYSV), from 'kdeinit

Additional info:

[root@localhost drwhite]# rpm -q --qf '%{sourcerpm}' -f /usr/bin/kdeinit
[root@localhost drwhite]# gdb /usr/bin/kdeinit core.29303
GNU gdb Red Hat Linux (5.2.1-4)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
Core was generated by `kdeinit: kdesktop        '.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libDCOP.so.4...done.
Loaded symbols for /usr/lib/libDCOP.so.4
Reading symbols from /usr/lib/libkparts.so.2...done.
Loaded symbols for /usr/lib/libkparts.so.2
Reading symbols from /usr/lib/libkio.so.4...done.
Loaded symbols for /usr/lib/libkio.so.4
Reading symbols from /usr/lib/libkdeui.so.4...done.
Loaded symbols for /usr/lib/libkdeui.so.4
Reading symbols from /usr/lib/libkdefx.so.4...done.
Loaded symbols for /usr/lib/libkdefx.so.4
Reading symbols from /usr/X11R6/lib/libXrender.so.1...done.
Loaded symbols for /usr/X11R6/lib/libXrender.so.1
Reading symbols from /usr/lib/libkdesu.so.4...done.
Loaded symbols for /usr/lib/libkdesu.so.4
Reading symbols from /usr/lib/libkdecore.so.4...done.
Loaded symbols for /usr/lib/libkdecore.so.4
Reading symbols from /usr/lib/qt-3.0.5/lib/libqt-mt.so.3...done.
Loaded symbols for /usr/lib/qt-3.0.5/lib/libqt-mt.so.3
Reading symbols from /usr/lib/libpng12.so.0...done.
Loaded symbols for /usr/lib/libpng12.so.0
Reading symbols from /usr/lib/libz.so.1...done.
Loaded symbols for /usr/lib/libz.so.1
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
---Type <return> to continue, or q <return> to quit---
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /lib/i686/libpthread.so.0...done.
Loaded symbols for /lib/i686/libpthread.so.0
Reading symbols from /lib/libdl.so.2...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /lib/libresolv.so.2...done.
Loaded symbols for /lib/libresolv.so.2
Reading symbols from /usr/lib/libstdc++.so.5...done.
Loaded symbols for /usr/lib/libstdc++.so.5
Reading symbols from /lib/libgcc_s.so.1...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libutil.so.1...done.
Loaded symbols for /lib/libutil.so.1
Reading symbols from /lib/i686/libm.so.6...done.
Loaded symbols for /lib/i686/libm.so.6
Reading symbols from /lib/i686/libc.so.6...done.
Loaded symbols for /lib/i686/libc.so.6
Reading symbols from /usr/lib/libcups.so.2...done.
Loaded symbols for /usr/lib/libcups.so.2
Reading symbols from /usr/lib/libmng.so.1...done.
Loaded symbols for /usr/lib/libmng.so.1
Reading symbols from /usr/lib/libjpeg.so.62...done.
Loaded symbols for /usr/lib/libjpeg.so.62
Reading symbols from /usr/lib/libGL.so.1...done.
Loaded symbols for /usr/lib/libGL.so.1
Reading symbols from /usr/X11R6/lib/libXmu.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXmu.so.6
Reading symbols from /usr/lib/libXft.so.2...done.
Loaded symbols for /usr/lib/libXft.so.2
Reading symbols from /usr/lib/libfontconfig.so.1...done.
Loaded symbols for /usr/lib/libfontconfig.so.1
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/libssl.so.2...done.
Loaded symbols for /lib/libssl.so.2
Reading symbols from /lib/libcrypto.so.2...done.
Loaded symbols for /lib/libcrypto.so.2
Reading symbols from /usr/lib/libGLcore.so.1...done.
Loaded symbols for /usr/lib/libGLcore.so.1
Reading symbols from /usr/X11R6/lib/libXt.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.6
Reading symbols from /usr/lib/libfreetype.so.6...done.
Loaded symbols for /usr/lib/libfreetype.so.6
---Type <return> to continue, or q <return> to quit---
Reading symbols from /usr/lib/libexpat.so.0...done.
Loaded symbols for /usr/lib/libexpat.so.0
Reading symbols from /usr/lib/libkonq.so.4...done.
Loaded symbols for /usr/lib/libkonq.so.4
Reading symbols from /usr/lib/kdesktop.so...done.
Loaded symbols for /usr/lib/kdesktop.so
Reading symbols from /usr/X11R6/lib/X11/locale/common/xlcUTF8Load.so.2...done.
Loaded symbols for /usr/X11R6/lib/X11/locale/common/xlcUTF8Load.so.2
Reading symbols from /usr/X11R6/lib/X11/locale/common/ximcp.so.2...done.
Loaded symbols for /usr/X11R6/lib/X11/locale/common/ximcp.so.2
Reading symbols from /usr/lib/kde3/plugins//styles/keramik.so...done.
Loaded symbols for /usr/lib/kde3/plugins//styles/keramik.so
Reading symbols from /lib/libnss_files.so.2...done.
Loaded symbols for /lib/libnss_files.so.2
Reading symbols from /usr/X11R6/lib/X11/locale/common/xomGeneric.so.2...done.
Loaded symbols for /usr/X11R6/lib/X11/locale/common/xomGeneric.so.2
#0  0x4212b26a in main_arena () from /lib/i686/libc.so.6
(gdb)

Comment 1 Kyle 2002-11-03 03:04:15 UTC
additional core file core.4337 generated from kdeinit sig 11.

core.4337: ELF 32-bit LSB core file of 'kdeinit' (signal 11), Intel 80386,
version 1 (SYSV), from 'kdeinit'

Comment 2 Kyle 2002-11-03 03:13:16 UTC
debug output of core.4337:


root@localhost drwhite]# gdb /usr/bin/artsshell core.4337
GNU gdb Red Hat Linux (5.2.1-4)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...

warning: core file may not match specified executable file.
Core was generated by `kdeinit: kdesktop        '.
Program terminated with signal 11, Segmentation fault.
#0  0x682c6770 in ?? ()


Comment 3 Ngo Than 2004-09-14 09:22:06 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.