Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77195 - dia crashes when text tool is selected through menu
Summary: dia crashes when text tool is selected through menu
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dia
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-11-02 21:17 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-06 16:01:25 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-02 21:17:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
Dia crashes with a segfault when the menu is used to select the text tool (but
not when the text tool is selected from the palette).

Version-Release number of selected component (if applicable):
Gnome dia 0.88.1


How reproducible:
Always

Steps to Reproduce:
1. Open dia, create a new diagram
2. Right-click on diagram to get menu
3. Select Tools > Text
	

Actual Results:  Dialog box saying that dia crashed due to a segfault

Expected Results:  I should have gotten a text tool

Additional info:

Comment 1 Havoc Pennington 2002-12-19 23:24:48 UTC
We should probably grab a new version of dia and see if it's fixed.

Comment 2 Alan Horkan 2003-01-04 18:14:59 UTC
Just about everything in the Tools Menu of Dia 0.88 caused a crash.  

RedHat 8 seems to ship with Dia 0.90 
(i am not my own sysadmin on this network i am using today)

Dia 0.90 is way way behind Dia CVS which has been ported to Gnome 2 but
unfortunately Dia developement is not quite well organised enought to make more
regular releases.  Passing of any patches back upstream would be of massive help.  
I am sure help stablising Dia for releases would be appreciated by the
developers.  There are also additional shapesets in CVS that have been added
since  0.90



Comment 3 Alexander Larsson 2003-01-06 16:01:25 UTC
The Dia in RH8.0 does not have this problem, and you should be able to use that
in 7.3 too.

It's unfortunate that dia for gnome 2 isn't in a releaseable state yet...


Note You need to log in before you can comment on or make changes to this bug.