Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7719 - halt script shuts down RAID dirty
Summary: halt script shuts down RAID dirty
Keywords:
Status: CLOSED DUPLICATE of bug 7681
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-10 01:09 UTC by zbeckman
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-13 16:13:52 UTC


Attachments (Terms of Use)

Description zbeckman 1999-12-10 01:09:22 UTC
Aigh! The 6.1 release (and RPM update) both have this bug. I hate someone.
Please open /etc/rc.d/init.d/halt and look at this logic:

... stuff ...
# Unmount file systems...
... more stuff ...
runcmd "Unmounting proc file system" umount /proc
... eh? ...
# turn off raid
if [ -x /sbin/raidstop -a -f /etc/raidtab ]; then
    # we can not use raidstop -a here because this will only stop
    # devices listed in the default config file which is not always
    # the case. So we look only for the active raid devices
    if [ -f /proc/mdstat ] ; then
        mddevs=$(grep ^md /proc/mdstat | awk '{ print $1 }')
... EH???! ...

This can, of course, be fixed by moving the umount /proc to AFTER examining
and shutting down RAID devices. Works for me.

zbeckman@creativesun.com

Comment 1 Bill Nottingham 1999-12-13 16:13:59 UTC
*** This bug has been marked as a duplicate of 7681 ***


Note You need to log in before you can comment on or make changes to this bug.