Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77183 - Running "mail" crashes with floating point exception on 4-line window
Summary: Running "mail" crashes with floating point exception on 4-line window
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailx
Version: 7.3
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-02 15:35 UTC by James Hunt
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-03 10:38:25 UTC


Attachments (Terms of Use)

Description James Hunt 2002-11-02 15:35:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
If you run "mail" in a window with *exactly* 4 lines, and if you do have atleast
1 email in your inbox, mail will crash:

[jdhunt@huntj:jdhunt> mail
Mail version 8.1 6/6/93.  Type ? for help.
"/var/spool/mail/jdhunt": 1 message 1 unread
Floating point exception
[jdhunt@huntj:jdhunt> echo $?
136
[jdhunt@huntj:jdhunt> 

If your terminal window (xterm, aterm, Eterm) has 3 lines, or 5 lines, the
problem does not occur.

If your window has > 4 lines, setting "LINES=4" does not reproduce the problem.
The number of columns the window has is not relevant.

I am able to reproduce this problem consistently on 2 different RH7.3 boxes
running the same version of mail.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ensure you have some email in /var/spool/mail/<user>
2.resize terminal emulator window to *exactly* 4 lines
3.run, "mail".
	

Actual Results:  mail command crashed with a floating point exception.

Expected Results:  mail should have produced a summary line, 1 for each email in
my inbox, followed by a command prompt (line beginning with '& ').

Additional info:

Comment 1 James Hunt 2004-10-06 14:40:35 UTC
James here again. Fedora Core 2 still has this problem.
"rpm -q mailx" returns, "mailx-8.1.1-32".

If it is any help, the Debian folk fixed this problem back in 2002.
Here's the bug report (#170784) I raised with them:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=170784&archive=yes

Thanks in advance,

James.

Comment 2 Ivana Varekova 2004-11-03 12:29:14 UTC
Thank you for your notice.
The problem was fixed.
IV

Comment 3 Ivana Varekova 2004-12-03 10:38:25 UTC
Solved with -40.


Note You need to log in before you can comment on or make changes to this bug.