Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77177 - cups blocks parallel port
Summary: cups blocks parallel port
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-02 11:45 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-09 16:10:13 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-02 11:45:02 UTC
Cups 1.1.14 1.1.15 and 1.1.16
often block parallel port after a print job is removed.

The lprm command often leaves parallel port in busy state because of process

parallel:/dev/lp0 288 root testprint.ps 1

is still running.
I am not sure about the other backends, but they seems have the same problem
as parallel.

To reproduce: Print a file to a printer that is out of a paper.
Then, even after a job is removed, the process parallel is still running.

[root@ tty]#lpq -Plp
lp is ready and printing
Rank    Owner   Job     File(s)                         Total Size
active  root    289     testprint.ps                    15360 bytes
[root@ tty]# lprm -Plp 289
[root@ tty]# lpq -Plp
lp is ready
no entries
[root@ tty]# ps axuww|grep parall
root      1263  0.0  0.5  2696  684 ?        S    04:55   0:00 parallel:/dev/lp0
289 root testprint.ps 1 

this process block other printing job accessing parallel port.

Comment 1 Tim Waugh 2003-04-09 16:10:13 UTC
Pretty sure I fixed this in Red Hat Linux 9.  Please reopen if you still see
that behaviour.


Note You need to log in before you can comment on or make changes to this bug.