Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77174 - PS/2 mouse not detected
Summary: PS/2 mouse not detected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-02 07:58 UTC by Marcus Moeller
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:09 UTC


Attachments (Terms of Use)

Description Marcus Moeller 2002-11-02 07:58:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I4 ve got simple 3 Button PS/2 mouse. The mouse was detected during installation
of RH8.

During the first reboot (after installation) kudzu displays that there is no
generic PS/2 mouse available and asks me to keep configuration / remove
configuration / ignore.

   To make it clear: I tried every possibility - none of them caused any action.

So when I tried to log in, the mouse AND the keyboard freezes. I tired to plug
in several PS/2 mouses but the result is the same. Here is a desciption what I4
ve already tired.

- tried to take a look at /proc/pci to see if IRQ 12 (that is assigned to a PS/2
mouse by default) is already used -> it4 s not

- tried to take a look at /proc/isapnp to see if IRQ 12 is already used -> that4
s what I4 ve found:

...
 Logical device 3 'ESS0002:Unknown'
    Compatible device PNP0600
    Device is active
    Active port 0x168,0x36e
    Active IRQ 12 [0x2]
    Resources 0
...

So I guess that there is a conflict with that sound card. It is a ESS ES1868
Plug and Play AudioDrive.

Perhaps anyone could tell me how to fix that issue






Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot into system
2.kudzu starts
3.ps/2 mouse is not detected

	

Actual Results:  X freezes, Mouse and Keyboard do not work

Expected Results:  X should work

Additional info:

Comment 1 Bill Nottingham 2002-11-04 20:39:53 UTC
The kernel should not be assigning IRQ 12 to anything with the PnP code, almost
surely.

Comment 2 Bugzilla owner 2004-09-30 15:40:09 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.