Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77154 - UID Limitations (think 16 bit uid_t) and its results
Summary: UID Limitations (think 16 bit uid_t) and its results
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel
Version: 2.1
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Larry Woodman
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 20:57 UTC by Jonathon M. Robison
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 20:57:36 UTC


Attachments (Terms of Use)

Description Jonathon M. Robison 2002-11-01 20:57:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; F-5.0.1SP1-
20000718; F-5.0.1-20000221)

Description of problem:
UID's above 50000 (I have tried from 52000 to 900000) or so fail to work, in 
that the home directory is show as owned by a numeric that ISNT the user's UID. 
In addition, programs like ssh (into the box) and sudo die w/o giving help for 
users whose UID is that high.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install Default AS2.1 (we use a kickstart)
2.useradd -u 625625 tester
3.ls -al /home/ and see that tester's home dir is owned by a number around 34000
4. Now try ssh into the box from another one.
5. Give tester sudo access and try using it as tester
	

Actual Results:  sudo says "killed", and ssh won't let you in.

Expected Results:  able to execute sudo commands, able to ssh in.

Additional info:

This is on the default kernel. On my laptop, I used the kernel-i686.config and 
made my own kernel (to enable LVM). THAT kernel does not have this problem. The 
unmodified kernel on the Dell PowerEdge server does.

Comment 1 Jonathon M. Robison 2002-11-13 13:46:36 UTC
This problem seems to be gone in the updated kernel, 2.4.9-e.9


Note You need to log in before you can comment on or make changes to this bug.