Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77148 - root menu becomes inaccessible
Summary: root menu becomes inaccessible
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 19:54 UTC by Joel Uckelman
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 19:54:14 UTC


Attachments (Terms of Use)

Description Joel Uckelman 2002-11-01 19:54:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
Sometimes when using sawfish, my root menu will stop working for no reason I've
been able to determine. I discovered (as a result of being impatient for things
to load) that I can achieve the same effect by middle-clicking while sawfish is
starting. The only way I've been able to make the root menu work again is by
logging out and starting a new session. (Can sawfish be restarted from within
sawfish-client? That might work, too.) This isn't terribly urgent, since it
would never cause data loss or anything like that---the apps keep working fine
after the root menu becomes unavailable---though it is really annoying when it
happens.

Version-Release number of selected component (if applicable):
2.0-4

How reproducible:
Always

Steps to Reproduce:
1. Log in to X.
2. Middle click while x apps are starting from .xsession.
3. Now, instead of bringing up the root menu on a middle click, sawfish will say
"*** Error: Menu already active" in your .xsesson-errors each time you try.

Additional info:

Comment 1 Havoc Pennington 2002-11-01 21:06:34 UTC
Moved to http://bugzilla.gnome.org/show_bug.cgi?id=97441

closing on Red Hat level


Note You need to log in before you can comment on or make changes to this bug.