Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77139 - httpd-devel (and other std. packages) in limbo after install
Summary: httpd-devel (and other std. packages) in limbo after install
Keywords:
Status: CLOSED DUPLICATE of bug 75736
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 17:13 UTC by Robert Steinfeldt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 17:13:48 UTC


Attachments (Terms of Use)

Description Robert Steinfeldt 2002-11-01 17:13:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
When one installs Redhat 8.0 for the first time, they are given a version of the
redhat-config-packages manager which allows them to 'select individual
packages', along WITH the major categories like 'X Window System', 'Gnome
Workstation' and 'Kernel Development'.

If, after installation, you again run 'redhat-config-packages', individual
package selection is not present.

The problem is that many packages which ARE a part of the Redhat standard RPM
packages (such as httpd-devel) but have not been categorized by the package
manager cannot be installed BY the package manager. Installers in this case must
resort to command line installation of these packages (and, of course, the
package manager never acknowledges the installation of these packages because it
doesn't show them in the first place).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load redhat-config-packages after a successful installation.
2. Attempt to install httpd-devel (a standard package included with 8.0) through
its interface.
	

Actual Results:  httpd-devel was not available to install through the package
manager at all, so I resorted to 'rpm --install httpd-devel-*.rpm, after
manually mounting RH 8.0 disc 3 for i386 (and the trial and error to determine
what disc the package was actually on). I'm sure there are other packages for
which this is true.

Expected Results:  redhat-config-packages should have the ability to install any
package that is included with the standard distribution, through the package
manager.

Additional info:

I base this bug submission on the assumption that the package manager wants to
be able to install any package which originally came with the Redhat
installation. This isn't a request to handle foreign RPMs, but those which
should already be handled by the installer.

Comment 1 Jeremy Katz 2002-11-01 17:34:58 UTC

*** This bug has been marked as a duplicate of 75736 ***


Note You need to log in before you can comment on or make changes to this bug.