Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77130 - cannot set utf-8 as preferred encoding
Summary: cannot set utf-8 as preferred encoding
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xemacs
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 16:00 UTC by diego.santacruz
Modified: 2015-01-08 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-19 08:42:17 UTC


Attachments (Terms of Use)

Description diego.santacruz 2002-11-01 16:00:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Tried setting the preferred encoding in xemacs to utf-8, but I get the error
"Can't prefer the 'utf-8' coding system". Since now UTF-8 is the default
encoding in Red Hat 8.0, it should be possible to set UTF-8 in xemacs as the
preferred coding.

Version-Release number of selected component (if applicable):
xemacs-21.4.8-16

How reproducible:
Always

Steps to Reproduce:
1. Set the preferred coding to UTF-8 with 'Esc-x prefer-coding-system' anb then
'utf-8'
2.
3.
	

Actual Results:  xemacs refuses to set the coding to UTF-8 with the message
"Can't prefer the 'utf-8' coding system"

Expected Results:  Be able to set UTF-8 as the preferred coding so that new
files are written in UTF-8.

Additional info:

Currently one has to manually set the coding to UTF-8 before opening each file,
which is a pain.
Not using UTF-8 creates all types of problems when attempting to read the file
with more or less (since they will assume UTF-8).

Comment 1 Jens Petersen 2002-11-11 06:28:50 UTC
Yes, I have also noticed this.

http://list-archive.xemacs.org/xemacs-nt/200206/msg00038.html

Comment 2 Jens Petersen 2003-04-17 12:58:59 UTC
Utf-8 coding configuration should be improved in xemacs-21.4.12-8
in rawhide shortly.

Comment 3 Jens Petersen 2003-05-19 08:42:17 UTC
Closing for now.


Note You need to log in before you can comment on or make changes to this bug.