Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77118 - After install and running up2date, the /var/lib/rpm/Packages file is now claimed to be in an unexpected file type
Summary: After install and running up2date, the /var/lib/rpm/Packages file is now clai...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 12:53 UTC by Michael Sinz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 12:53:51 UTC


Attachments (Terms of Use)

Description Michael Sinz 2002-11-01 12:53:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1b) Gecko/20020813

Description of problem:
After the base install I did an up2date.  Everything worked as expected.

Today, I tried running up2date and it failed.  Running rpm with --rebuilddb
option shows the following error:

rpmdb: /var/lib/rpm/Packages: unexpected file type or format
error: cannot open Packages index

I do not know how to recover and would prefer not to need to reinstall the
system again.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

I have not spent the time trying to reproduce as I was working on getting a disk
ready for some of my work projects.

The one other item is that I do have XFS kernel installed since I am doing
things with XFS.

I am currently stuck as I can not load my RPMs on the system, which is part of
what I am testing right now.

Comment 1 Jeff Johnson 2002-11-01 14:16:20 UTC
If the file type of Packages has changed, you should
look carefully at your disk parameters. It's very unlikely
that this happened through program usage, much more likely
that you have file system or disk corruption.


Note You need to log in before you can comment on or make changes to this bug.