Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77115 - Wrong file globbing behavior
Summary: Wrong file globbing behavior
Keywords:
Status: CLOSED DUPLICATE of bug 74701
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 77339 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 11:21 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 23:52:59 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-01 11:21:46 UTC
Description of Problem:

If I do a

   $ ls [a-z]*

to get all filename beginning with a lowercase letter it also shows
files beginning with uppercase letters

Version-Release number of selected component (if applicable):

[jan@torgau jan]$ bash --version
GNU bash, version 2.05b.0(1)-release (i686-pc-linux-gnu)
Copyright (C) 2002 Free Software Foundation, Inc.


How Reproducible:


Steps to Reproduce:
1. ls [a-z]*
2. 
3. 

Actual Results:
s.a.

Expected Results:
s.a.

Additional Information:

Comment 1 Need Real Name 2002-11-01 15:11:50 UTC
I just checked it as "root" user.
There it works as expected.

Comment 2 giulioo 2002-11-01 16:06:26 UTC
I think this is expected behavior.
Try setting LC_COLLATE=C and then retry.




Comment 3 Need Real Name 2002-11-01 18:59:48 UTC
The "LC_COLLATE=C" didn't change anything

Comment 4 Miloslav Trmac 2002-11-01 23:52:53 UTC
You'll need to use bash-2.05-7 from rawhide for changes to have
immediate effect.
To see the result without upgrading, do
LC_COLLATE=C bash -c 'ls [a-z]*'


Comment 5 Tim Waugh 2002-11-02 16:27:53 UTC

*** This bug has been marked as a duplicate of 74701 ***

Comment 6 Tim Waugh 2002-11-05 14:00:18 UTC
*** Bug 77339 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.