Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77107 - Evolution crashes when printing html emails with images blocked
Summary: Evolution crashes when printing html emails with images blocked
Keywords:
Status: CLOSED DUPLICATE of bug 76028
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-print
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 09:59 UTC by tarm
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:04 UTC


Attachments (Terms of Use)

Description tarm 2002-11-01 09:59:38 UTC
Description of problem:
When external images are not displayed in html emails, evolution crashes when I
try to print the text only email, giving the message: "Application
'Evolution-mail' (process ###) has crashed due to a fatal error.  (Segmentation
fault)"

Version-Release number of selected component (if applicable): 1.0.8


How reproducible:
Always

Steps to Reproduce:
1.Block external images from being displayed in html emails in Evolution. 
(default perhaps, I can't remember)
2.Open an html email with blocked images (most commercial ones).
3.Print to lpr

Comment 1 Jeremy Katz 2002-11-05 18:24:35 UTC
Looks like the crash is in gnome-print.  Backtrace from the relevant thread

0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x403e8c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x40b9f8bd in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#4  0x080c2569 in segv_redirect ()
#5  0x403ea47e in __pthread_sighandler () from /lib/i686/libpthread.so.0
#6  <signal handler called>
#7  0x4207a4f3 in strlen () from /lib/i686/libc.so.6
#8  0x40a6638b in t1_get_glyph_name () from /usr/lib/libfreetype.so.6
#9  0x40a370ab in FT_Get_Glyph_Name () from /usr/lib/libfreetype.so.6
#10 0x4062a26e in gff_pso_ensure_buffer_t1 () from /usr/lib/libgnomeprint.so.15
#11 0x40629c1b in gnome_font_face_pso_ensure_buffer ()
   from /usr/lib/libgnomeprint.so.15
#12 0x405f520b in gnome_print_ps2_close () from /usr/lib/libgnomeprint.so.15
#13 0x405ddc1b in gnome_print_context_close ()
   from /usr/lib/libgnomeprint.so.15
#14 0x405fbf20 in gpf_close () from /usr/lib/libgnomeprint.so.15
#15 0x405ddc1b in gnome_print_context_close ()
   from /usr/lib/libgnomeprint.so.15
#16 0x405d3825 in gnome_print_master_print () from /usr/lib/libgnomeprint.so.15
#17 0x08091240 in do_mail_print ()
#18 0x4033fc37 in impl_Bonobo_UIComponent_execVerb ()
   from /usr/lib/libbonobox.so.2
#19 0x402e4f79 in _ORBIT_skel_Bonobo_UIComponent_execVerb ()
   from /usr/lib/libbonobo.so.2
#20 0x40d519cc in ORBit_POA_handle_request () from /usr/lib/libORBit.so.0
#21 0x40d54599 in ORBit_handle_incoming_request () from /usr/lib/libORBit.so.0
#22 0x40d6bf99 in giop_main_handle_connection () from /usr/lib/libIIOP.so.0
#23 0x40d16bac in orb_handle_connection () from /usr/lib/liboaf.so.0
#24 0x40f34076 in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#25 0x40f3597e in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#26 0x40f35e59 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#27 0x40f360f4 in g_main_run () from /usr/lib/libglib-1.2.so.0
#28 0x40e346df in gtk_main () from /usr/lib/libgtk-1.2.so.0
#29 0x402f7a2e in bonobo_main () from /usr/lib/libbonobo.so.2
#30 0x080c273a in main ()
#31 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6


Comment 2 Owen Taylor 2003-01-07 20:42:49 UTC

*** This bug has been marked as a duplicate of 76028 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.