Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77100 - Mozilla hangs on a flash enabled www site with an mp3 playing
Summary: Mozilla hangs on a flash enabled www site with an mp3 playing
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mozilla
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 05:16 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-01 05:16:11 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-01 05:16:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Mozilla loads the flash plugin, which tries to open /dev/dsp and when it can't,
the browser hangs until the mp3 player (mpg123) stops.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run mpg123 <mp3>
2. start mozilla, browse to a flash site (www.reason.com works for me)

	

Actual Results:  Mozilla hangs until the mp3 stops playing

Expected Results:  Web page should continue to load to completion...  sharing
the sound device?

Additional info:

This is probably a flash bug...  strace shows mozilla doing an open on /dev/dsp
when the hang occurs, so its obviously a sound related problem.  I can't believe
I'm the only one experiencing this...

Comment 1 Christopher Blizzard 2002-11-01 23:11:07 UTC
Get the flash 6 beta.  It's fixed there.  I can't fix this since it's a flash
problem, not a moz problem.


Note You need to log in before you can comment on or make changes to this bug.