Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77085 - up2date crashes with python errors
Summary: up2date crashes with python errors
Keywords:
Status: CLOSED DUPLICATE of bug 77017
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 22:28 UTC by Wes Barris
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-02 01:29:41 UTC


Attachments (Terms of Use)

Description Wes Barris 2002-10-31 22:28:51 UTC
Description of Problem:

up2date crashes with python errors at the "Packages Flagged
to be Skipped" section.

Version-Release number of selected component (if applicable):

default 8.0 fresh install, no other updates

How Reproducible:

always

Steps to Reproduce:
1. up2date -> next -> next
2. 
3. 

Actual Results:
root@cecil# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1066, in onChannelsPageNext
    self.pkgList = self.pList.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 258, in
getPackagesToInstall
    result = self.__skipPackages(result)
  File "/usr/share/rhn/up2date_client/packageList.py", line 285, in __skipPackages
    packageList = self.__skipFiles(packageList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 306, in __skipFiles
    ignoreMsgCallback = self.ignoreMsgCallback)
  File "/usr/share/rhn/up2date_client/packageList.py", line 365, in buildHeaderList
    hdr = headerList[pkg]
  File "/usr/share/rhn/up2date_client/headers.py", line 121, in __getitem__
    self.__retrievePackage(item)
  File "/usr/share/rhn/up2date_client/headers.py", line 126, in __retrievePackage
    hdr, sourceType = rpcServer.doCall(rpmSource.psc.headerSource.getHeader, item)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 107, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 239, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 666, in getHeader
    fd = self.s.getPackageHeader(channel, filename)
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 141, in request
    return self.parse_response(fd)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 157, in
parse_response
    p.feed(response)
  File "/usr/lib/python2.2/xmlrpclib.py", line 390, in feed
    self._parser.Parse(data, 0)
xml.parsers.expat.ExpatError: not well-formed (invalid token): line 1, column 0
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1109, in onSkippedPagePrepare
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: min() or max() arg is an empty sequence


Expected Results:


Additional Information:
This bug looks similar to another that has been reported but
with a different set of traceback results.

Comment 1 john.hosage 2002-11-02 01:29:33 UTC
I had the same problem last night.  But tonight it worked.  My system was a
fresh install.  I used the GUI up2date interface both times.

My machine is a Pentium Pro 200 with 64MB memory.  Did a text install because
the graphical crashes with only 64MB memory.  Package selection was custom,
selecting individual packages.

Comment 2 will jones 2002-11-04 20:56:07 UTC

*** This bug has been marked as a duplicate of 77017 ***


Note You need to log in before you can comment on or make changes to this bug.