Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77083 - A bar chart report only shows numbers
Summary: A bar chart report only shows numbers
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Bugzilla
Classification: Community
Component: Test
Version: 2.17
Hardware: i386
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 22:20 UTC by Göran Uddeborg
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-02 16:10:11 UTC


Attachments (Terms of Use)
The resulting report (deleted)
2002-10-31 22:20 UTC, Göran Uddeborg
no flags Details

Description Göran Uddeborg 2002-10-31 22:20:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Trying to do a bar chart gave me a picture with only distributed numbers in the
chart.  No bars as far as I could see.  And I don't understand what the numbers
would mean, the whole thing seems broken.

How reproducible:
Always

Steps to Reproduce:
1.Try the graphical report
2.Select component on vertical axis
3.Select resolution on horizontal axis
4.Select format "bar chart"
5.Select "plot data sets" individually
6.Select bugs with reporter goeran@uddeborg.pp.se
7.Generate
	

Actual Results:  The resulting picture is enclosed.

Comment 1 Göran Uddeborg 2002-10-31 22:20:53 UTC
Created attachment 82965 [details]
The resulting report

Comment 2 David Lawrence 2002-12-02 05:49:46 UTC
Problem is with resolution I would imagine. Please try this with a smaller list
of components and see if the bars become visible properly. Looks like it is
trying to squeeze alot of info into a small area. The resolution is hard coded
and would need to be changed upstream in the mainline Bugzilla code.

Comment 3 Göran Uddeborg 2002-12-02 12:53:57 UTC
Is the URL still https://bugzilla.redhat.com/rh-bugzilla-beta3/ ?

I've tried to reach it a few times during the weekend.  (Because a comment from
you on the 26:th which seems to have been removed again.)  But only got error
messages back.  I'm not sure if it has been the same message all times, but
right now it says:

Bugzilla is currently broken. Please try again later. If the problem persists,
please contact dkl@redhat.com. The error you should quote is: FATAL 1:  Database
"bugs_rc1" does not exist in the system catalog. at globals.pl line 124.

Comment 4 David Lawrence 2002-12-02 15:38:18 UTC
Oops. Sorry it is now https://bugzilla.redhat.com/rh-bugzilla-rc2.

Comment 5 Göran Uddeborg 2002-12-02 16:10:04 UTC
Yes, that worked better.  And fter stripping down to just 9 packages, I could
see the bars.

If possible, I think it would be nice with some kind of warning about this in
the  bugzilla interface.  If the warning comes up only when applicable, only
when I have choosen too many packages, that would of course be best.  It wasn't
obvious to me I was choosing too many packages, and somebody else might make the
same mistake.

But in any case, your assumption about the cause of the problem seems to have
been correct.

Comment 6 David Lawrence 2002-12-02 16:29:43 UTC
This should actually be reported in the upstream Bugzilla tree since the person
who originally re-wrote the new charting tool, may  have not realized the effect
when alot of components are chosen. I have filed a bug at bugzilla.mozilla.org
with this info so please follow along there.

http://bugzilla.mozilla.org/show_bug.cgi?id=183017

Comment 7 Göran Uddeborg 2002-12-02 17:06:11 UTC
So this is a standard function of Bugzilla!  That was new to me.  (I'll have to
check if we have that at our installation at work! :-)

I'm CC:ing myself on the mozilla.org version.


Note You need to log in before you can comment on or make changes to this bug.