Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77081 - non newline terminated output ignored
Summary: non newline terminated output ignored
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 22:06 UTC by Bowe Strickland
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-29 19:41:18 UTC


Attachments (Terms of Use)

Description Bowe Strickland 2002-10-31 22:06:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
while running, for example, cat /proc/self/cmdline, no output is generated. 
strace demonstrates output is written to stdout.

for example:

[root@server1 root]# cat /proc/self/cmdline
[root@server1 root]#

[root@server1 root]# strace cat /proc/self/cmdline
(...)
open("/proc/self/cmdline", O_RDONLY|O_LARGEFILE) = 3
fstat64(3, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
read(3, "cat\0/proc/self/cmdline\0", 4096) = 23
write(1, "cat\0/proc/self/cmdline\0", 23cat/proc/self/cmdline) = 23
read(3, "", 4096)                       = 0
(...)

strings of the same, however, is correct (strings adds newline termination):

[root@server1 root]# strings /proc/self/cmdline
strings
/proc/self/cmdline
[root@server1 root]#





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cat /proc/self/cmdline
2.
3.
	

Additional info:

Comment 1 Miloslav Trmac 2002-11-01 12:29:49 UTC
Duplicate of 74383, although I'm not sure whether the bug is in bash, terminal
emulators or terminfo/termcap descriptions.

Comment 2 Miloslav Trmac 2003-12-13 14:12:37 UTC
This is fixed at least in FC 1
Triage->Close


Note You need to log in before you can comment on or make changes to this bug.