Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77080 - Reload button does not work.
Summary: Reload button does not work.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ggv
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
: 77324 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 21:44 UTC by Gustavo Maciel Dias Vieira
Modified: 2013-04-02 04:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-03-03 22:09:41 UTC


Attachments (Terms of Use)

Description Gustavo Maciel Dias Vieira 2002-10-31 21:44:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
Clicking the reload button does not reload the .ps or .pdf document currently
open. The "watch file" option does not work either.
Reopening the file works.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a file, say generated through dvips.
2. Regenerate it.
3. Click reload.
	

Actual Results:  The screen is refreshed with the *old* file contents.

Expected Results:  The screen is refreshed with the *new* file contents.

Additional info:

I tested it with a local mounted and with a NFS mounted fs and got the same bug.

Comment 1 Jonathan Blandford 2002-11-10 13:53:26 UTC
*** Bug 77324 has been marked as a duplicate of this bug. ***

Comment 2 Yaron Minsky 2002-12-02 16:59:35 UTC
I've noticed that GV does not seem to have this problem for ps files.  However,
for PDF files, GV puts up an error message when the reloading:

Error: /syntaxerror in --token--
Operand stack:
   --dict:5/5(L)--   3499   3   0   3   2115900   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostringval-- 
 2   %stopped_push   --nostringval--   --nostringval--   --nostringval--  
--nostringval--   --nostringval--   --nostringval--   --nostringval--  
--nostringval--   --nostringval--
Dictionary stack:
   --dict:1050/1123(ro)(G)--   --dict:0/20(G)--   --dict:93/200(L)--  
--dict:97/127(ro)(G)--   --dict:229/230(ro)(G)--   --dict:19/24(L)--  
--dict:4/6(L)--   --dict:19/20(L)--
Current allocation mode is local
GNU Ghostscript 7.05: Unrecoverable error, exit code 1


Comment 3 Jonathan Blandford 2003-01-15 23:07:00 UTC
Fixed in rawhide.

Comment 4 Bart Martens 2004-03-03 06:14:46 UTC
*** Bug 117169 has been marked as a duplicate of this bug. ***

Comment 5 Bart Martens 2004-03-03 06:18:53 UTC
Reopening.

Is the rawhide fix broken?
Or is the rawhide fix not yet in FC1?


Comment 6 Gustavo Maciel Dias Vieira 2004-03-03 21:09:57 UTC
At the time the rawhide fix was ok.
I'm using FC1, ggv-2.4.0.1-1, and everything is still ok.


Comment 7 Tethys 2004-03-03 21:58:59 UTC
Curious, because ggv-2.4.0.1-1 on FC1 still *does* have the problem
for me...

Comment 8 Bart Martens 2004-03-03 22:09:41 UTC
Marking this bug back to "closed rawhide", the way it was.

Tethys, two other people just tested this with ggv-2.4.0.1-1, and the
reload button seems to work fine. Let's go back to bug #117169.



Note You need to log in before you can comment on or make changes to this bug.