Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77078 - firstboot tracebacks on a dirty system
Summary: firstboot tracebacks on a dirty system
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 20:59 UTC by Pete Zaitcev
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:31:39 UTC


Attachments (Terms of Use)
/etc/ntp.conf @mellorn.sfbay.redhat.com (deleted)
2002-11-18 18:26 UTC, Pete Zaitcev
no flags Details

Description Pete Zaitcev 2002-10-31 20:59:25 UTC
Description of Problem:

firstboot tracebacks with:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 151, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 149, in __init__
    ntpStatus = mainWindow.dateBackend.isNtpRunning()
  File "/usr/share/redhat-config-date/dateBackend.py", line 163, in isNtpRunning
   line = output[0]
IndexError: list index out of range

The traceback occurs in an X11 window, then saved to a file in ~root.

Version-Release number of selected component (if applicable):

firstboot-1.0.1-10

How Reproducible:

Unknown

Steps to Reproduce:
1. Install and configure text login (e.g. init level 3), configure stuff, etc.
2. Edit /etc/inittab and change default runlevel to 5
3. Reboot with <ctrl-alt-del>

Actual Results:

Traceback

Expected Results:

Working

Additional Information:

I think the firstboot might have been confused by running on top of
an "unclean" system which was in operation for a while, so it's not
really the "first" boot.

Comment 1 Brent Fox 2002-11-18 16:18:20 UTC
Can you attach /etc/ntp.conf?  It looks like something in that file is a
breaking the parser.

Comment 2 Pete Zaitcev 2002-11-18 18:26:49 UTC
Created attachment 85486 [details]
/etc/ntp.conf @mellorn.sfbay.redhat.com

Comment 3 Pete Zaitcev 2002-11-18 18:29:32 UTC
Indeed, I changed ntp.conf on that box. Look at the line:
server clock2.corp.redhat.com


Comment 4 Brent Fox 2002-11-18 18:41:04 UTC
I'm sorry.  The code isn't breaking in the file parser, it's with trying to
parse the return value of the ntp init script.  Please try running
'/sbin/service ntpd stats' and attach the output to the report.

Comment 5 Pete Zaitcev 2002-11-18 18:46:22 UTC
[zaitcev@mellorn zaitcev]$ service ntpd stats
Usage: /etc/init.d/ntpd {start|stop|restart|condrestart|status}
[zaitcev@mellorn zaitcev]$ service ntpd status
ntpd (pid 725) is running...
[zaitcev@mellorn zaitcev]$


Comment 6 Brent Fox 2003-01-30 15:23:31 UTC
I've changed the isNtpRunning function to check the return value of the
initscript instead of trying to parse the output of the initscript, so this
shouldn't happen anymore.  Please reopen if you see this behavior in Phoebe, but
I'm reasonably certain that this bug has been fixed.

QA, please verify with redhat-config-date-1.5.9-1.

Comment 7 Brent Fox 2003-05-25 14:31:39 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.


Note You need to log in before you can comment on or make changes to this bug.