Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77069 - mailx badly handles certain changes in mailbox
Summary: mailx badly handles certain changes in mailbox
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailx
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 18:48 UTC by Josko Plazonic
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-03 10:01:36 UTC


Attachments (Terms of Use)
Simpe change to improve mails checking of mailbox status upon exit (deleted)
2002-10-31 18:49 UTC, Josko Plazonic
no flags Details | Diff

Description Josko Plazonic 2002-10-31 18:48:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
If mailbox, open by mail, gets shorter (e.g. because edited by another mail 
session) mail program will not detect that and it overwrites new mailbox with 
an old copy that it had in memory.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open a mailbox folder with mail, make some small change.
2. Open it another time (with mail for example), delete a couple of emails and 
quit saving changes so that effect is a shorter mailbox.
3. Quit the mail program from step 1 saving changes.
	

Actual Results:  Result is the mailbox from 1) any changes made in the meantime 
are lost.  

Expected Results:  Mail should detect that mailbox got shorter and it should 
abort any changes.  

Additional info:

Mail also doesn't do any checking when mailbox got longer, what if again this 
was a result of action by another mail program.  Simple "fix" - check if added 
stuff begins with "From ".

Comment 1 Josko Plazonic 2002-10-31 18:49:30 UTC
Created attachment 82944 [details]
Simpe change to improve mails checking of mailbox status upon exit

Comment 2 Ivana Varekova 2004-11-16 14:08:30 UTC
Thank you for your notice.
The problem was fixed.
IV

Comment 3 Ivana Varekova 2004-12-03 10:01:36 UTC
Solved with -40.


Note You need to log in before you can comment on or make changes to this bug.