Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77061 - Mouse becomes non functional after using with right config.
Summary: Mouse becomes non functional after using with right config.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 17:06 UTC by Adam Julius
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-26 17:52:23 UTC


Attachments (Terms of Use)
/etc/sysconfig/mouse (deleted)
2002-10-31 18:17 UTC, Adam Julius
no flags Details
/etc/X11/XF86Config (deleted)
2002-10-31 18:20 UTC, Adam Julius
no flags Details

Description Adam Julius 2002-10-31 17:06:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
I currently have my mouse working and detected by Redhat 8.  But if I go to the 
mouse gui config area and leave the correct config alone and then click through 
as if im leaving the settings alone, my mouse becomes unusable afterwards.  My 
mouse is a Labtec Optical Wheelmouse, and I use the Microsoft Intellimouse ps/2 
option which works fine in all programs and in Redhat linux 8.0 if I do not 
enter the Mouse configuration program.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to Graphical mouse config
2. Keep mouse settings the same and click through all default settings
3. Use mouse.  


	

Additional info:

Comment 1 Brent Fox 2002-10-31 17:37:36 UTC
A few questions for you:

1) When you first run the program, what mouse is selected in the list?

2) Is the mouse misbehaving in X or in console or both?

3) Can you attach the contents of /etc/sysconfig/mouse and /etc/X11/XF86Config?





Comment 2 Adam Julius 2002-10-31 18:17:33 UTC
Created attachment 82924 [details]
/etc/sysconfig/mouse

Comment 3 Adam Julius 2002-10-31 18:20:15 UTC
Created attachment 82925 [details]
/etc/X11/XF86Config

Comment 4 Adam Julius 2002-10-31 18:25:27 UTC
1) When you first run the program, what mouse is selected in the list?

Microsoft Intellimouse PS/2

2) Is the mouse misbehaving in X or in console or both?

What happens is that the Gnome stops working right and the mouse pattern becomes
unusable.  If I click on the redhat in the lower left start menu, it wont show
me the menu choices.  So I know it doesnt work in X.  But I dont know about
console.  How would I check this when it doesnt work under X?  

3) Can you attach the contents of /etc/sysconfig/mouse and /etc/X11/XF86Config?
I attached both of them before I enter mouseconfig.  If you want the ones after
as well, please advise.  




Comment 5 Brent Fox 2002-10-31 19:43:11 UTC
Ok, wait a minute.  Did you run redhat-config-mouse or mouseconfig?  

And yes, the contents of the files after running the program would be
interesting as well.

Comment 6 Adam Julius 2002-10-31 20:09:03 UTC
I ran the graphical mouse program from gnome, which is redhat-mouse-config 
correct?  I said mouseconfig in my previous post which was a typo.  Sorry about 
the confusion.  How would I manually get into mozilla without my mouse from a 
regular windows keyboard?  If I can figure that out, I can easily send over the 
attachments.  Thanks.  



Comment 7 Brent Fox 2002-10-31 20:17:50 UTC
Ok, I was confused there for a second.  I don't know how to navigate mozilla
without a mouse.  Maybe you could have an xterm open, run the tool, Alt-Tab back
into the terminal and make copies of the files to the /tmp directory, then run
the tool again to unbreak the mouse.  Then start mozilla and attach the files
you copied into /tmp?  Would that work?

Comment 8 Adam Julius 2002-11-01 16:03:28 UTC
I notice that if I click on close window in the mouse area, the mouse type 
works.  But if I click ok with the default mouse setting it messes it up.

Ill try what you said.

Comment 9 Brent Fox 2002-12-15 15:42:34 UTC
Any more info here?

Comment 10 Brent Fox 2003-02-26 17:52:23 UTC
Closing due to lack of information.


Note You need to log in before you can comment on or make changes to this bug.