Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77054 - up2date crash after python is installed with the same up2date
Summary: up2date crash after python is installed with the same up2date
Keywords:
Status: CLOSED DUPLICATE of bug 77017
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 14:20 UTC by Need Real Name
Modified: 2015-01-08 00:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-31 15:51:05 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-31 14:20:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
up2date is broken after the python packages were updated/installed through the
same up2date:

$# up2date --install pine

Fetching package list for channel: redhat-linux-i386-8.0...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-8.0...
########################################

Fetching rpm headers...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 801, in ?
    main()
  File "/usr/sbin/up2date", line 573, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 737, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 55, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 89, in
__findPackagesToUpdate
    self.availableUpdates = plist.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 258, in
getPackagesToInstall
    result = self.__skipPackages(result)
  File "/usr/share/rhn/up2date_client/packageList.py", line 285, in __skipPackages
    packageList = self.__skipFiles(packageList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 306, in __skipFiles
    ignoreMsgCallback = self.ignoreMsgCallback)
  File "/usr/share/rhn/up2date_client/packageList.py", line 365, in buildHeaderList
    hdr = headerList[pkg]
  File "/usr/share/rhn/up2date_client/headers.py", line 121, in __getitem__
    self.__retrievePackage(item)
  File "/usr/share/rhn/up2date_client/headers.py", line 126, in __retrievePackage
    hdr, sourceType = rpcServer.doCall(rpmSource.psc.headerSource.getHeader, item)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 107, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 239, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 666, in getHeader
    fd = self.s.getPackageHeader(channel, filename)
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 141, in request
    return self.parse_response(fd)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 157, in
parse_response
    p.feed(response)
  File "/usr/lib/python2.2/xmlrpclib.py", line 390, in feed
    self._parser.Parse(data, 0)
xml.parsers.expat.ExpatError: not well-formed (invalid token): line 1, column 0


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.up2date --install python
2.up2date --install <some new pkg>
3.
	

Actual Results:  See above

Expected Results:  up2date with valid status

Additional info:

Comment 1 Need Real Name 2002-10-31 15:37:08 UTC
I am running RH 8.0 (fresh install..desktop level).  I had been using the 
up2date just fine the past couple of days.  I am a newbie so I wanted to try a 
few things.  I reinstalled RH8.0 with the Workstation level (reformatted the 
drive too) but when I went to use up2date last night (Oct 30/31), I got the 
same errors as the gentlemen above. I know this because I ran up2date from the 
command line.  I have another drive with 7.3 on it and it is currently updating 
(10:31AM-EST 10/21/2002) just fine.  Is this a problem with RH8 or did the 
problem get resolved between 9:30AM EST 10/31/2002 and now (10:31AM-EST 
10/21/2002) ?

Comment 2 Mihai Ibanescu 2002-10-31 15:50:57 UTC
We did some experimental changes on the server side, trying to compress headers.
A bug in rhnlib (from what I can tell) prevents the 8.0 client from
understanding compressed rpm headers, therefore we backed up the change. Should
work fine now.

Comment 3 Mihai Ibanescu 2002-10-31 15:53:34 UTC

*** This bug has been marked as a duplicate of 77017 ***

Comment 4 Need Real Name 2002-10-31 16:31:12 UTC
Add I bought a service package thinking it would help.  :-p

Comment 5 Need Real Name 2002-10-31 21:31:57 UTC
It works now ..

Comment 6 Mihai Ibanescu 2002-10-31 21:56:42 UTC
edward.clark: no, we are not _that_ sick :-)


Note You need to log in before you can comment on or make changes to this bug.