Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77039 - glibc-2.2.93-5 + MySQL-3.23.52-3 = seg fault in _nss_dns_gethostbyaddr_r
Summary: glibc-2.2.93-5 + MySQL-3.23.52-3 = seg fault in _nss_dns_gethostbyaddr_r
Keywords:
Status: CLOSED DUPLICATE of bug 77467
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-31 07:57 UTC by tanner
Modified: 2016-11-24 14:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-07 07:45:40 UTC


Attachments (Terms of Use)

Description tanner 2002-10-31 07:57:14 UTC
Description of Problem:

mysql-3.23.52-3 seg faults on remote network connects. Using the mysql client,
and running mysqld under the debugger. I get this:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 24580 (LWP 6865)]
0x40014098 in _nss_dns_gethostbyaddr_r () from /lib/libnss_dns.so.2
(gdb) bt
#0  0x40014098 in _nss_dns_gethostbyaddr_r () from /lib/libnss_dns.so.2
#1  0x40267cc1 in gethostbyaddr_r@@GLIBC_2.1.2 () from /lib/libc.so.6
#2  0x40267ada in gethostbyaddr () from /lib/libc.so.6
#3  0x080e8476 in ip_to_hostname(in_addr*, unsigned*) (in=0x83d460c,
    errors=0xbf3ff978) at hostname.cc:192
#4  0x080e8faf in check_connections (thd=0x83d4218) at sql_parse.cc:344
#5  0x080e9452 in handle_one_connection(void*) (arg=0xbf3ffd9c)
    at sql_parse.cc:534
#6  0x4003376e in pthread_start_thread () from /lib/libpthread.so.0
#7  0x400337dd in pthread_start_thread_event () from /lib/libpthread.so.0


Version-Release number of selected component (if applicable):

Comment 1 Need Real Name 2002-10-31 22:25:05 UTC
Just wanted to mention that an upgrade to glibc 2.3.1 (built from Rawhide
SRPM's) resolved this problem on our end. So, it is definetly a problem with
MySQL<->glibc interaction (if not a bug in glibc itself).

Comment 2 Marcel Telka 2002-11-07 07:45:34 UTC
This bug is similar to bug 75128.

Comment 3 Jakub Jelinek 2002-12-04 16:51:11 UTC

*** This bug has been marked as a duplicate of 77467 ***


Note You need to log in before you can comment on or make changes to this bug.