Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77017 - up2date bomb out
Summary: up2date bomb out
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhnlib
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Jay Turner
URL:
Whiteboard:
: 77019 77054 77085 (view as bug list)
Depends On:
Blocks: 57770
TreeView+ depends on / blocked
 
Reported: 2002-10-31 01:16 UTC by Milan Kerslager
Modified: 2015-01-08 00:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-16 18:22:38 UTC


Attachments (Terms of Use)

Description Milan Kerslager 2002-10-31 01:16:05 UTC
I had a fresh install of RH 8.0. I registered machine with up2date --register.
Then run up2date -u. I've got this tracebac:

# locale
LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=

# up2date -u

Fetching package list for channel: redhat-linux-i386-8.0...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-8.0...
########################################

Fetching rpm headers...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 801, in ?
    main()
  File "/usr/sbin/up2date", line 573, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 737, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 55, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 89, in
__findPackagesToUpdate
    self.availableUpdates = plist.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 258, in
getPackagesToInstall
    result = self.__skipPackages(result)
  File "/usr/share/rhn/up2date_client/packageList.py", line 285, in __skipPackages
    packageList = self.__skipFiles(packageList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 306, in __skipFiles
    ignoreMsgCallback = self.ignoreMsgCallback)
  File "/usr/share/rhn/up2date_client/packageList.py", line 365, in buildHeaderList
    hdr = headerList[pkg]
  File "/usr/share/rhn/up2date_client/headers.py", line 121, in __getitem__
    self.__retrievePackage(item)
  File "/usr/share/rhn/up2date_client/headers.py", line 126, in __retrievePackage
    hdr, sourceType = rpcServer.doCall(rpmSource.psc.headerSource.getHeader, item)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 107, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 239, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 666, in getHeader
    fd = self.s.getPackageHeader(channel, filename)
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 141, in request
    return self.parse_response(fd)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 157, in
parse_response
    p.feed(response)
  File "/usr/lib/python2.2/xmlrpclib.py", line 390, in feed
    self._parser.Parse(data, 0)
xml.parsers.expat.ExpatError: not well-formed (invalid token): line 1, column 0

Comment 1 Milan Kerslager 2002-10-31 01:23:41 UTC
At the same time other system works ok (an up-to-date system which was
registered few days ago). So RHN server semms to be up (maybe wrong reply in
this reported case).

Comment 2 Mihai Ibanescu 2002-10-31 15:53:26 UTC
*** Bug 77054 has been marked as a duplicate of this bug. ***

Comment 3 Mihai Ibanescu 2002-10-31 15:54:21 UTC
*** Bug 77019 has been marked as a duplicate of this bug. ***

Comment 4 Mihai Ibanescu 2002-10-31 15:59:05 UTC
Should be "fixed" now. Can you please confirm?
[we tried to re-enable rpm header compressions and they were never tested with
the 8.0 client, therefore we didn't know they are broken. Hmmm. Reassigning to
rhnlib i.e. myself :-(
]

Comment 5 G.T. 2002-10-31 17:57:55 UTC
up2date works now! Thank you for  your help!


Comment 6 Milan Kerslager 2002-10-31 21:59:20 UTC
I have been able to run up2date succesfully.
I tryed to downgrade fetchmail and run up2date again. It works.
Seems to be fixed. Thanx.

Comment 7 Mihai Ibanescu 2002-10-31 22:02:15 UTC
Leaving this open to track the rhnlib bug.

Comment 8 will jones 2002-11-04 20:56:00 UTC
*** Bug 77085 has been marked as a duplicate of this bug. ***

Comment 9 Dimitrie O. Paun 2002-11-05 01:53:49 UTC
yes, it's fixed, thanx!


Note You need to log in before you can comment on or make changes to this bug.