Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76984 - FAMOpen failed, FAMErrno=0
Summary: FAMOpen failed, FAMErrno=0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fam
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-30 16:05 UTC by juha.heljoranta
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-05 15:43:42 UTC


Attachments (Terms of Use)

Description juha.heljoranta 2002-10-30 16:05:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
Starting the X (gnome-panel?), Nautilus or Gedit produces error messages
'FAMOpen failed, FAMErrno=0' to console. Creating a new folder to desktop causes
also an error.

New users won't see panel (waited few mins and then Ctrl-M-Backspace'd).
However, the desktop is working but slowly.

Old users will see the panel, but it takes a long time to load.
Short-cuts (eg. M-F1) won't work until panel has appeared.

Using nautilus to navigate directories takes lots of time and produces about
five errors per directory change.

Starting X as an old user produces at least 25 errors and the final error is:
Key
/apps/panel/profiles/default/objects/0t1034612756ut935295u500p1025r1382828353k3221219628/launcher_location
is not set, can't load launcher

After this, the panel shows up and short-cuts starts to work (eg. M-F1).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Additional info:

Error to console:
FAMOpen failed, FAMErrno=0

Nothing unusual in log files and rpm -Vva does not report anything that should
relate to this. Should you need any logs/info, just let me know :)

related bug:
76153
and
http://bugzilla.gnome.org/show_bug.cgi?id=83368

I've been using 8.0 since the release and it has worked fine. Until now. I have
no idea what is corrupted (if any).

Comment 1 Alexander Larsson 2002-11-05 12:20:31 UTC
Try upgrading to the latest xinetd errata and restart xinetd + portmap. I think
that should fix it.


Comment 2 juha.heljoranta 2002-11-05 15:43:34 UTC
FAM is bounded to portmap and I had filtered portmap like this:
-A RH-Lokkit-0-50-INPUT -p tcp -m tcp -s! xxx.xxx.xxx.xxx --dport 111 -j REJECT
By removing line above from my /etc/sysconfig/iptables everything works again.

I got a clue from:
https://listman.redhat.com/pipermail/limbo-list/2002-August/002378.html

And google found something like this
http://www.der-keiler.de/Mailing-Lists/securityfocus/security-basics/2002-03/1197.html

So this is known issue. I guess that this is now resolved. I will open a new bug
against rhl-sg component to get this documented.



Note You need to log in before you can comment on or make changes to this bug.