Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76964 - dependencies problems RHBA-2002-140
Summary: dependencies problems RHBA-2002-140
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL: http://rhn.redhat.com/errata/RHBA-200...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-30 10:18 UTC by Need Real Name
Modified: 2015-01-08 00:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-27 23:43:05 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-30 10:18:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
The packages have some dependencies problems. I think that is not posible 
because all updates posted by Redhat are executed at my machine. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

[root@VuurMuur /root]# cd /sambashares/linux/rhn
[root@VuurMuur rhn]# rpm -Fvh *.rpm
error: failed dependencies:
       python-xmlrpc >= 1.4.4 is needed by rhn_register-2.8.27-1.7.1
       mkinitrd >= 3.2.2 is needed by up2date-2.8.39-1.7.1
       python-xmlrpc >= 1.5.0 is needed by up2date-2.8.39-1.7.1
       up2datepoptmodule.so is needed by up2date-2.8.39-1.7.1 

	

Actual Results:  No updated up2date package and rnh package.

Additional info:

Did i missed something or what?

Comment 1 Mihai Ibanescu 2002-11-25 15:14:57 UTC
rpm -Fvh will not install new packages that are required by the current set of
packages. I.e., if you have package foo version 1 installed, and you try to rpm
-Fvh package foo version 2 (which additionally requires package bar), the
transaction will fail.

Please try to rpm -Uvh python-xmlrpc python-popt mkinitrd before trying the
above, and let us know what the result is.

Comment 2 Mihai Ibanescu 2003-02-27 23:43:05 UTC
Closing, no response.


Note You need to log in before you can comment on or make changes to this bug.