Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76957 - installer crashes on auto disk partition
Summary: installer crashes on auto disk partition
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-30 05:25 UTC by Andrew Dunstan
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-13 21:28:16 UTC


Attachments (Terms of Use)

Description Andrew Dunstan 2002-10-30 05:25:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
see crash dump below

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Select to wipe out and install on /dev/hda
2. Cry
3.
	

Actual Results:  Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/autopart.py", line 1160, in doAutoPartition
    (errors, warnings) = partitions.sanityCheckAllRequests(diskset)
  File "/usr/lib/anaconda/partitions.py", line 767, in sanityCheckAllRequests
    swapSize = swapSize + request.getActualSize(self, diskset)
  File "/usr/lib/anaconda/partRequests.py", line 422, in getActualSize
    raise RuntimeError, "Checking the size of a partition which hasn't been 
allocated yet"
RuntimeError: Checking the size of a partition which hasn't been allocated yet

Local variables in innermost frame:
self: New Part Request -- mountpoint: None uniqueID: 265
  type: swap  format: 1  badblocks: None
  device: None drive: ['hda']  primary: None
  size: 128  grow: 1  maxsize: 256
  start: None  end: None  migrate: None  origfstype: None
part: None
diskset: <partedUtils.DiskSet instance at 0x869a64c>
partitions: <partitions.Partitions instance at 0x833951c>


Additional info:

Comment 1 Michael Fulbright 2002-10-30 21:48:25 UTC
What does the partition table on this drive look like before you tried to wipe
it out?

Comment 2 Andrew Dunstan 2002-10-30 23:46:55 UTC
The partition table had a single fat32 partition on it. I discovered after 
filing the bug that the workaround was to use W98 fdisk to remove the 
partition and then things proceeded smoothly (it's installing as I type). 
Still, the interface gives the impression it will handle this for you, and 
then throws an ugly and fairly uninformative exception.

Comment 3 Michael Fulbright 2003-03-13 21:28:16 UTC
I cannot reproduce this issue. It may be a parted issue with certain non-parted
created partition tables but there isn't any way to tell without having a
machine with the problem available to us.


Note You need to log in before you can comment on or make changes to this bug.