Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76942 - Bad: NFS TCP client takes 10 minutes for recovery
Summary: Bad: NFS TCP client takes 10 minutes for recovery
Keywords:
Status: CLOSED DUPLICATE of bug 77465
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: nfs-utils
Version: 2.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Stephen Tweedie
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-29 21:24 UTC by dan chan
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-10-31 16:00:51 UTC


Attachments (Terms of Use)

Description dan chan 2002-10-29 21:24:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
Bad: NFS TCP client takes 10 minutes or more to recovery an active socket after 
a NFS server failover.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mount a file system using mount option nfsvers=3, proto=tcp (For 
example /test)
2. mount /test
3. cd /test
4. dd if=/dev/zero of=testdata
5. Failover a NFS server.
	

Actual Results:  It will take 10 to 12 minutes before the nfs client able to 
access the mount point.

Expected Results:  After the NFS server completely failover, NFS client should 
able to access the mount point.

Additional info:

There is a patch in 2.5 kernel fixing this particular problem for NFS client. 
RedHat need to port the patch to AS2.1.

Comment 1 Stephen Tweedie 2002-11-07 18:22:21 UTC

*** This bug has been marked as a duplicate of 77465 ***


Note You need to log in before you can comment on or make changes to this bug.