Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76930 - kernel-bigmem hangs on OSB4 chipset
Summary: kernel-bigmem hangs on OSB4 chipset
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-29 16:44 UTC by John Dalbec
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:08 UTC


Attachments (Terms of Use)
lspci -vvx output (deleted)
2002-10-30 14:48 UTC, John Dalbec
no flags Details
dmesg output (deleted)
2002-10-31 17:50 UTC, John Dalbec
no flags Details
dmesg output from 2.4.18 (deleted)
2002-10-31 22:12 UTC, John Dalbec
no flags Details

Description John Dalbec 2002-10-29 16:44:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
kernel-bigmem-2.4.18-17.7.x.i686.rpm hangs while booting on an IBM xSeries 232
(single processor, 512M).  kernel-enterprise-2.4.9-34.i686.rpm does not.

ServerWorks OSB4: IDE controller on PCI bus 00 dev 79
ServerWorks OSB4: chipset revision 0
--- hang occurs here ---
ServerWorks OSB4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x0840-0x0847, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0x0848-0x084f, BIOS settings: hdc:pio, hdd:pio


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install kernel-bigmem-2.4.18-17.7.x.i686.rpm on IBM xSeries 232 running Red
Hat 7.1.
2. Try to boot.
	

Actual Results:  Kernel hangs probing IDE chipset

Expected Results:  Normal boot

Additional info:

I tried passing ide=nodma at the LILO prompt but no luck.
I tried passing ide=nodma,noprobe at the LILO prompt but no luck.
Sometimes the hang occurs a line or two later (depending on arguments?)

Comment 1 John Dalbec 2002-10-29 16:48:08 UTC
lspci sez:
00:00.0 Host bridge: ServerWorks CNB20HE (rev 23)
00:00.1 Host bridge: ServerWorks CNB20HE (rev 01)
00:00.2 Host bridge: ServerWorks: Unknown device 0006 (rev 01)
00:00.3 Host bridge: ServerWorks: Unknown device 0006 (rev 01)
00:06.0 VGA compatible controller: S3 Inc. Savage 4 (rev 06)
00:0f.0 ISA bridge: ServerWorks OSB4 (rev 51)
00:0f.1 IDE interface: ServerWorks: Unknown device 0211
00:0f.2 USB Controller: ServerWorks: Unknown device 0220 (rev 04)
01:02.0 SCSI storage controller: Adaptec AHA-294x / AIC-7884U (rev 01)
01:07.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 0c)
02:04.0 RAID bus controller: IBM Netfinity ServeRAID controller
02:05.0 SCSI storage controller: Adaptec 7892A (rev 02)
02:09.0 SCSI storage controller: Adaptec 7899P (rev 01)
02:09.1 SCSI storage controller: Adaptec 7899P (rev 01)


Comment 2 John Dalbec 2002-10-30 14:48:13 UTC
Created attachment 82704 [details]
lspci -vvx output

Comment 3 John Dalbec 2002-10-30 14:52:03 UTC
/proc/pci/serverworks:
                                ServerWorks 0x0211 Chipset.
------------------------------- General Status ---------------------------------
--------------- Primary Channel ---------------- Secondary Channel -------------
                 enabled                          enabled
--------------- drive0 --------- drive1 -------- drive0 ---------- drive1 ------
DMA enabled:    yes              yes             no                no 
UDMA enabled:   yes              yes             no                no 
UDMA enabled:   2                0               2                 0
DMA enabled:    2                2               ?                 ?
PIO  enabled:   ?                ?               ?                 ?


Comment 4 John Dalbec 2002-10-30 14:53:46 UTC
I meant /proc/ide/svwks, sorry.

Comment 5 John Dalbec 2002-10-30 22:24:53 UTC
The kernel-debug RPM boots fine.  It looks like this may be the SMP interrupt
routing issue that others have complained about.

Comment 6 John Dalbec 2002-10-31 17:50:51 UTC
Created attachment 82906 [details]
dmesg output

Comment 7 John Dalbec 2002-10-31 18:35:21 UTC
kernel-bigmem boots fine with "noapic".

Comment 8 John Dalbec 2002-10-31 22:09:03 UTC
The .config fix from bug #74937 also works.

Comment 9 John Dalbec 2002-10-31 22:12:03 UTC
Created attachment 82964 [details]
dmesg output from 2.4.18

Comment 10 Bugzilla owner 2004-09-30 15:40:08 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.