Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76922 - [Alt Gr] is acting strangely under console.
Summary: [Alt Gr] is acting strangely under console.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: console-tools
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-29 14:05 UTC by Ivo Sarak
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-23 20:53:04 UTC


Attachments (Terms of Use)

Description Ivo Sarak 2002-10-29 14:05:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
If, under console, to press [Alt Gr] when [Num Lock] in ON - result is a
character '0'.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Choose a console (not under X);
2.Press the [Num Lock] so "Num Lock" light goes OFF;
3.Press [Alt Gr] several times;
4.Press the [Num Lock] so "Num Lock" light goes ON;
5.Press [Alt Gr] several times;
	

Actual Results:  In case [Num Lock] is ON there will be as many '0' as there was
[Alt Gr] pressed under point 5.

Expected Results:  Nothing should appear.

Additional info:

Comment 1 ttlquestor 2002-11-03 14:21:00 UTC
I have the same problem with a Belgian keyboard
If i reboot the machine i can log in the console with as many normal users if i
like and the alt key works normal, from the moment i log in as root on 1 of the
consoles the alt key produces a '0' when pressed in all tty's... even at the
login prompt the problem is there... under x the alt key sometimes work normal
and after typing some other text it suddenly generates some unprintable chars
followed by bbbbbb... endlessly repeating until another key is pressed.

Greetings,
ttl

Comment 2 Eido Inoue 2004-08-23 20:53:04 UTC
can't reproduce with current release.


Note You need to log in before you can comment on or make changes to this bug.