Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 76919 - default registry entries missing
Summary: default registry entries missing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wine
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-29 13:36 UTC by Markku Kolkka
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-16 16:12:49 UTC


Attachments (Terms of Use)
script of "wine Setup.exe" (deleted)
2002-10-29 13:37 UTC, Markku Kolkka
no flags Details

Description Markku Kolkka 2002-10-29 13:36:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Trying to install a Windows program (CARA 2.1,
http://www.cara.de/ENU/index.html) fails with:

ERROR: You need to merge the 'winedefault.reg' file into your
       Wine registry by running: `regedit winedefault.reg'

fixme:ole:_LocalServerThread CoMarshalInterface failed, 80070057!

ERROR: You need to merge the 'winedefault.reg' file into your
       Wine registry by running: `regedit winedefault.reg'

fixme:ole:_LocalServerThread CoMarshalInterface failed, 80070057!

The "winecheck" recommended by WineHQ
(http://home.nexgo.de/andi.mohr/download/winecheck) also reports a critical
setup error:

027. Checking availability of winedefault.reg entries...    CRITICAL (entry
"SHAREDMEMLOCATION" not found in system.reg registry file).
- ADVICE: file winedefault.reg, the most basic wine registry environment,
doesn't seem to have been applied using regapi.

There's no "winedefault.reg" file anywhere in the system after installing the
wine RPM.


Version-Release number of selected component (if applicable):
wine-20020605-2

How reproducible:
Always

Steps to Reproduce:
1.Install wine
2.Try to install CARA 2.1 by "wine /mnt/cdrom/Setup.exe"
3.
	

Actual Results:  Setup locks up after showing the setup language dialog and
needs to be stopped with ctrl-C. 

Additional info:
Full script of wine run attached.

Comment 1 Markku Kolkka 2002-10-29 13:37:10 UTC
Created attachment 82524 [details]
script of "wine Setup.exe"

Comment 2 Thomas Woerner 2004-08-16 16:12:49 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.